aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-14 09:30:42 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 16:42:10 +0200
commitc060511f2fcdd380894e6e5557dad1e89f01a544 (patch)
tree0f9746c21d26c39ff0ca18a4189e8d6200854718
parenta8ef4978f29c3fb069066430587f331f61432f21 (diff)
downloadguix-c060511f2fcdd380894e6e5557dad1e89f01a544.tar
guix-c060511f2fcdd380894e6e5557dad1e89f01a544.tar.gz
gnu: Add rust-rand-pcg-0.2.
* gnu/packages/crates-io.scm (rust-rand-pcg-0.2): New variable. (rust-rand-pcg-0.1): Inherit from rust-rand-pcg-0.2. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5f74ed3efd..3a0263d504 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7950,10 +7950,10 @@ generator that uses the HC-128 algorithm.")
("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
("rust-winapi" ,rust-winapi-0.3))))))
-(define-public rust-rand-pcg-0.1
+(define-public rust-rand-pcg-0.2
(package
(name "rust-rand-pcg")
- (version "0.1.2")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
@@ -7961,17 +7961,31 @@ generator that uses the HC-128 algorithm.")
(file-name (string-append name "-" version ".crate"))
(sha256
(base32
- "0i0bdla18a8x4jn1w0fxsbs3jg7ajllz6azmch1zw33r06dv1ydb"))))
+ "0ab4h6s6x3py833jk61lwadq83qd1c8bih2hgi6yps9rnv0x1aqn"))))
(build-system cargo-build-system)
(home-page "https://crates.io/crates/rand_pcg")
(synopsis
- "Selected PCG random number generators")
+ "Selected PCG random number generators")
(description
- "Selected PCG random number generators")
+ "Implements a selection of PCG random number generators.")
(properties '((hidden? . #t)))
(license (list license:asl2.0
license:expat))))
+(define-public rust-rand-pcg-0.1
+ (package
+ (inherit rust-rand-pcg-0.2)
+ (name "rust-rand-pcg")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rand_pcg" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "0i0bdla18a8x4jn1w0fxsbs3jg7ajllz6azmch1zw33r06dv1ydb"))))))
+
(define-public rust-rand-xorshift-0.2
(package
(name "rust-rand-xorshift")