aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:52 +0100
committer宋文武 <iyzsong@member.fsf.org>2020-01-20 20:50:24 +0800
commita8ef4978f29c3fb069066430587f331f61432f21 (patch)
treecf4d68b50e11d0ddbbe0d5d98bf93c779165f06e
parent72c2478add21060d8318ddfe23cf3c16c1b3412b (diff)
downloadguix-a8ef4978f29c3fb069066430587f331f61432f21.tar
guix-a8ef4978f29c3fb069066430587f331f61432f21.tar.gz
gnu: Add python-gssapi.
* gnu/packages/python-xyz.scm (python-gssapi): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8dfbc8c363..617c3b4c7a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17258,3 +17258,34 @@ environments, and running Python unit tests inside those environments. It is
based on the file of the same name found alongside the MIT Kerberos 5 unit
tests.")
(license license:isc)))
+
+(define-public python-gssapi
+ (package
+ (name "python-gssapi")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gssapi" version))
+ (sha256
+ (base32
+ "1gymg4asvwrz7y13qpwp2s5g8qwq179d72gkj09q6bfcgs82l5wr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-six" ,python-six)))
+ (inputs
+ `(("mit-krb5" ,mit-krb5)))
+ ;; for tests
+ (native-inputs
+ `(("python-shouldbe" ,python-shouldbe)
+ ("python-parameterized" ,python-parameterized)
+ ("python-k5test" ,python-k5test)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/pythongssapi/python-gssapi")
+ (synopsis "Python GSSAPI Wrapper")
+ (description
+ "Python-GSSAPI provides both low-level and high level wrappers around the
+GSSAPI C libraries. While it focuses on the Kerberos mechanism, it should
+also be useable with other GSSAPI mechanisms.")
+ (license license:isc)))