aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:49 +0100
committer宋文武 <iyzsong@member.fsf.org>2020-01-20 20:50:24 +0800
commit9786258b4d6aabd686187c7eae9af5dfb523893a (patch)
tree3fd1d7320d8223d58e1421079715f31779eefe49
parent84efaa3b8ea8913f9a99f40d8d96a62f2dd41b8c (diff)
downloadguix-9786258b4d6aabd686187c7eae9af5dfb523893a.tar
guix-9786258b4d6aabd686187c7eae9af5dfb523893a.tar.gz
gnu: Add python-shouldbe.
* gnu/packages/python-xyz.scm (python-shouldbe): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 887c336883..eb61d828f9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17201,3 +17201,25 @@ and cuts down boilerplate code when testing libraries for asyncio.")
(synopsis "Patch python built-in objects")
(description "This project allows Python code to extend built-in types.")
(license (list license:gpl3+ license:expat))))
+
+(define-public python-shouldbe
+ (package
+ (name "python-shouldbe")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shouldbe" version))
+ (sha256
+ (base32
+ "16zbvjxf71dl4yfbgcr6idyim3mdrfvix1dv8b95p0s9z07372pj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-forbiddenfruit" ,python-forbiddenfruit)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/directxman12/should_be")
+ (synopsis "Python Assertion Helpers inspired by Shouldly")
+ (description
+ "Python Assertion Helpers inspired by Shouldly.")
+ (license license:isc)))