aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:50 +0100
committer宋文武 <iyzsong@member.fsf.org>2020-01-20 20:50:24 +0800
commit84efaa3b8ea8913f9a99f40d8d96a62f2dd41b8c (patch)
tree8b8b1ebc3425320eb8b830e3ea51b457516bae1d
parentd589f0d2bcb52f8d0c3524a72d7586fa39a2e051 (diff)
downloadguix-84efaa3b8ea8913f9a99f40d8d96a62f2dd41b8c.tar
guix-84efaa3b8ea8913f9a99f40d8d96a62f2dd41b8c.tar.gz
gnu: Add python-forbiddenfruit.
* gnu/packages/python-xyz.scm (python-forbiddenfruit): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f1b0f991c6..887c336883 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17172,3 +17172,32 @@ and cuts down boilerplate code when testing libraries for asyncio.")
(description
"@code{aionotify} is a simple, asyncio-based inotify library.")
(license license:bsd-3)))
+
+(define-public python-forbiddenfruit
+ (package
+ (name "python-forbiddenfruit")
+ (version "0.1.3")
+ (source
+ (origin
+ ;; Source tarball on PyPi lacks Makefile that builds and runs tests
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/forbiddenfruit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fp2xvdqpi910j9r3q68x38phpxbm700gjdi2m2j5gs91xdnyyh2"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "SKIP_DEPS=1"))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-coverage" ,python-coverage)))
+ (home-page "https://github.com/clarete/forbiddenfruit")
+ (synopsis "Patch python built-in objects")
+ (description "This project allows Python code to extend built-in types.")
+ (license (list license:gpl3+ license:expat))))