aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:51 +0100
committer宋文武 <iyzsong@member.fsf.org>2020-01-20 20:50:24 +0800
commit72c2478add21060d8318ddfe23cf3c16c1b3412b (patch)
tree5b4ee13fa314e3d8865c2eb15335c7af2f48c65e
parent9786258b4d6aabd686187c7eae9af5dfb523893a (diff)
downloadguix-72c2478add21060d8318ddfe23cf3c16c1b3412b.tar
guix-72c2478add21060d8318ddfe23cf3c16c1b3412b.tar.gz
gnu: Add python-k5test.
* gnu/packages/python-xyz.scm (python-k5test): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb61d828f9..8dfbc8c363 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
@@ -17223,3 +17224,37 @@ and cuts down boilerplate code when testing libraries for asyncio.")
(description
"Python Assertion Helpers inspired by Shouldly.")
(license license:isc)))
+
+(define-public python-k5test
+ (package
+ (name "python-k5test")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "k5test" version))
+ (sha256
+ (base32
+ "1lqp3jgfngyhaxjgj3n230hn90wsylwilh120yjf62h7b1s02mh8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ;; `which`, `kadmin.local` binaries called inside library
+ ("which" ,which)
+ ("mit-krb5" ,mit-krb5)))
+ (native-inputs `(("mit-krb5" ,mit-krb5)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* _
+ (substitute* "k5test/realm.py"
+ (("'kadmin_local'") "'kadmin.local'")))))))
+ (home-page "https://github.com/pythongssapi/k5test")
+ (synopsis "Library for setting up self-contained Kerberos 5 environments")
+ (description
+ "@code{k5test} is a library for setting up self-contained Kerberos 5
+environments, and running Python unit tests inside those environments. It is
+based on the file of the same name found alongside the MIT Kerberos 5 unit
+tests.")
+ (license license:isc)))