aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-14 09:22:31 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 11:16:35 +0200
commit56beba471bf33e2b831ee3c22a4ac66110521ba8 (patch)
treed6257b877bea6e1765145c377b2bc0fe399a0be7
parent2d92286de65845ae8eb13911711f15e9fae684dd (diff)
downloadguix-56beba471bf33e2b831ee3c22a4ac66110521ba8.tar
guix-56beba471bf33e2b831ee3c22a4ac66110521ba8.tar.gz
gnu: Add rust-rand-hc-0.2.
* gnu/packages/crates-io.scm (rust-rand-hc-0.2): New variable. (rust-rand-hc-0.1): Inherit from rust-rand-hc-0.2. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4f88c18877..87eaa741d4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7793,10 +7793,10 @@ useful types and distributions, and some randomness-related algorithms.")
`(#:skip-build? #t
#:cargo-inputs (("rand-core" ,rust-rand-core-0.4))))))
-(define-public rust-rand-hc-0.1
+(define-public rust-rand-hc-0.2
(package
(name "rust-rand-hc")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
@@ -7804,17 +7804,36 @@ useful types and distributions, and some randomness-related algorithms.")
(file-name (string-append name "-" version ".crate"))
(sha256
(base32
- "1i0vl8q5ddvvy0x8hf1zxny393miyzxkwqnw31ifg6p0gdy6fh3v"))))
+ "0g31sqwpmsirdlwr0svnacr4dbqyz339im4ssl9738cjgfpjjcfa"))))
+ (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
- #:cargo-inputs (("rust-rand-core" ,rust-rand-core-0.3))))
- (build-system cargo-build-system)
+ #:cargo-inputs
+ (("rust-rand-hc" ,rust-rand-core-0.5))))
(home-page "https://crates.io/crates/rand_hc")
(synopsis "HC128 random number generator")
- (description "HC128 random number generator")
+ (description "This package provides a cryptographically secure random number
+generator that uses the HC-128 algorithm.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-rand-hc-0.1
+ (package
+ (inherit rust-rand-hc-0.2)
+ (name "rust-rand-hc")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rand_hc" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1i0vl8q5ddvvy0x8hf1zxny393miyzxkwqnw31ifg6p0gdy6fh3v"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-rand-core" ,rust-rand-core-0.3))))))
+
(define-public rust-rand-isaac-0.1
(package
(name "rust-rand-isaac")