aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-13 22:04:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 09:40:01 +0200
commit317f925b7f4b7277cf3a79814bd7dbed8f1d1099 (patch)
treee7fe51e587add7475120df2f0605e691c205c9fe
parent1c8d53f8c5726610687f1ad228867b510dbfdf5f (diff)
downloadguix-317f925b7f4b7277cf3a79814bd7dbed8f1d1099.tar
guix-317f925b7f4b7277cf3a79814bd7dbed8f1d1099.tar.gz
gnu: Add node-color-name.
* gnu/packages/node-xyz.scm (node-color-name): New variable.
-rw-r--r--gnu/packages/node-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 03d1a60faf..44236ec469 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -22,6 +22,27 @@
#:use-module (guix git-download)
#:use-module (guix build-system node))
+(define-public node-color-name
+ (package
+ (name "node-color-name")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/colorjs/color-name")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09rbmj16nfwcwkhrybqxyy66bkrs50vpw6hkdqqb14l3gsyxpr74"))))
+ (build-system node-build-system)
+ (home-page "https://github.com/colorjs/color-name")
+ (synopsis "JSON with CSS color names")
+ (description
+ "This package provides a JSON list with color names and their values.")
+ (license license:expat)))
+
(define-public node-env-variable
(package
(name "node-env-variable")