aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-03 21:17:25 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commitef9dc9efa49a1db600805f3fbcd2dbfbabfb4ea4 (patch)
tree78cc2a3b46e4cff69386b2fcaba43aeb1aaf0f32
parent314ad6435c3999535f7461ceaeb0b32295d0b6b1 (diff)
downloadguix-ef9dc9efa49a1db600805f3fbcd2dbfbabfb4ea4.tar
guix-ef9dc9efa49a1db600805f3fbcd2dbfbabfb4ea4.tar.gz
gnu: Remove tlsdate.
As discussed in <https://bugs.gnu.org/46602>, tlsdate does not support a current release of OpenSSL. * gnu/packages/ntp.scm (tlsdate): Remove variable.
-rw-r--r--gnu/packages/ntp.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 191eedd158..55b9a73b22 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -216,54 +216,3 @@ secure, easy to configure, and accurate enough for most purposes, so it's more
minimalist than ntpd.")
;; A few of the source files are under bsd-3.
(license (list l:isc l:bsd-3))))
-
-(define-public tlsdate
- (package
- (name "tlsdate")
- (version "0.0.13")
- (home-page "https://github.com/ioerror/tlsdate")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (commit (string-append "tlsdate-" version))
- (url home-page)))
- (sha256
- (base32
- "0w3v63qmbhpqlxjsvf4k3zp90k6mdzi8cdpgshan9iphy1f44xgl"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system gnu-build-system)
- (arguments
- `(;; Disable seccomp when it's not supported--e.g., on aarch64. See
- ;; 'src/seccomp.c' for the list of supported systems.
- #:configure-flags ,(if (any (lambda (system)
- (string-contains (or
- (%current-target-system)
- (%current-system))
- system))
- '("x86_64" "i686" "arm"))
- ''()
- ''("--disable-seccomp-filter"))
-
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- ;; The ancestor of 'SOURCE_DATE_EPOCH'; it contains the
- ;; date that is recorded in binaries. It must be a
- ;; "recent date" since it is used to detect bogus dates
- ;; received from servers.
- (setenv "COMPILE_DATE" (number->string 1530144000))
- (invoke "sh" "autogen.sh"))))))
- (inputs `(("openssl" ,openssl-1.0)
- ("libevent" ,libevent)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (synopsis "Extract remote time from TLS handshakes")
- (description
- "@command{tlsdate} sets the local clock by securely connecting with TLS
-to remote servers and extracting the remote time out of the secure handshake.
-Unlike ntpdate, @command{tlsdate} uses TCP, for instance connecting to a
-remote HTTPS or TLS enabled service, and provides some protection against
-adversaries that try to feed you malicious time information.")
- (license l:bsd-3)))