aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-03-21 18:01:20 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-08-17 01:10:25 +0300
commitef4a931532fb8eac68ccff4f84d25005237e9a2f (patch)
treefb4884255b4b59c9264632e92a60e60653c020a1
parent43b7da5cb9a9d80d668a20ae1c44db87fb049a13 (diff)
downloadguix-ef4a931532fb8eac68ccff4f84d25005237e9a2f.tar
guix-ef4a931532fb8eac68ccff4f84d25005237e9a2f.tar.gz
gnu: Add pam-gnupg.
* gnu/packages/linux.scm (pam-gnupg): New variable.
-rw-r--r--gnu/packages/linux.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6f0bd5e285..803ef0d9bd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020, 2021 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
@@ -99,6 +99,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gstreamer)
@@ -1616,6 +1617,40 @@ at login. Local and dynamic reconfiguration are its key features.")
(description "This package provides a PAM interface using @code{ctypes}.")
(license license:expat)))
+(define-public pam-gnupg
+ (package
+ (name "pam-gnupg")
+ (version "0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cruegge/pam-gnupg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bf91gi6zmfzzmczxm7pajxdlgnikasvg5xsd3j0a368rcr7lf9l"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gnupg" ,gnupg)
+ ("linux-pam" ,linux-pam)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:tests? #f ;no tests suite
+ #:configure-flags
+ (list (string-append "--with-moduledir="
+ (assoc-ref %outputs "out") "/lib/security"))))
+
+ (home-page "https://github.com/cruegge/pam-gnupg")
+ (synopsis "Unlock GnuPG keys on login")
+ (description "This package provides a PAM module that hands over your
+login password to @code{gpg-agent}. This can be useful if you are using a
+GnuPG-based password manager like @code{pass}.")
+ (license license:gpl3+)))
+
;;;
;;; Miscellaneous.