aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-03 21:05:50 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:56 -0400
commitd90bb7edca6b8a780c4d1ffc78c57d20f78b364e (patch)
tree466e4d4f31acc9a5007282a8ee8e6860ecc2b737
parent8d80a708535546394deaea6489245ecc09b29131 (diff)
downloadguix-d90bb7edca6b8a780c4d1ffc78c57d20f78b364e.tar
guix-d90bb7edca6b8a780c4d1ffc78c57d20f78b364e.tar.gz
gnu: Remove dillo.
As discussed in <https://bugs.gnu.org/46602>, Dillo does not include a supported implementation of TLS / HTTPS, and there does not seem to be any activity upstream to improve that. * gnu/packages/web-browsers.scm (dillo): Remove variable.
-rw-r--r--gnu/packages/web-browsers.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5a928d9b46..a0a5498039 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -147,37 +147,6 @@ management, extensions such as advertisement blocker and colorful tabs.")
(home-page "https://www.midori-browser.org")
(license license:lgpl2.1+)))
-(define-public dillo
- (package
- (name "dillo")
- (version "3.0.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.dillo.org/download/"
- "dillo-" version ".tar.bz2"))
- (sha256
- (base32
- "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
- (build-system gnu-build-system)
- (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("fltk" ,fltk)
- ("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libxcursor" ,libxcursor)
- ("libxft" ,libxft)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("openssl" ,openssl-1.0) ;XXX try latest openssl for dillo > 3.0.5
- ("perl" ,perl)
- ("zlib" ,zlib)))
- (synopsis "Very small and fast graphical web browser")
- (description "Dillo is a minimalistic web browser particularly intended for
-older or slower computers and embedded systems.")
- (home-page "https://www.dillo.org")
- (license license:gpl3+)))
-
(define-public links
(package
(name "links")