aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-15 16:35:22 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:56 -0400
commita81dd42465abed547b23245d0fa5f9ea260b06a5 (patch)
treecefe16ef5cd062b6b9185ba1eecbd135d2710a68
parent94551439074f804f35970b08435aa02007edfb0b (diff)
downloadguix-a81dd42465abed547b23245d0fa5f9ea260b06a5.tar
guix-a81dd42465abed547b23245d0fa5f9ea260b06a5.tar.gz
Revert "gnu: syncthing: Prepare for cross-compiling."
This commit broke splitting the package into multiple outputs. See <https://bugs.gnu.org/50071>. This reverts commit b33f5d7ff0627424a06fd0416761cd81c350e20a.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5cb8449e44..d428099080 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -76,14 +76,6 @@
(("120s") "999s"))
#t))
- (add-before 'build 'pre-build
- (lambda _
- (with-directory-excursion "src/github.com/syncthing/syncthing"
- ;; Don't set a local GOBIN, it breaks cross compiling.
- (substitute* "build.go"
- ((".*GOBIN.*") "")))
- #t))
-
(replace 'build
(lambda _
(with-directory-excursion "src/github.com/syncthing/syncthing"
@@ -92,7 +84,7 @@
;; "build syncthing" again with -no-upgrade.
;; https://github.com/syncthing/syncthing/issues/6118
(invoke "go" "run" "build.go")
- (for-each delete-file (find-files "../../../../bin" "syncthing"))
+ (delete-file "bin/syncthing")
(invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
(replace 'check
@@ -106,11 +98,15 @@
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(utils (assoc-ref outputs "utils")))
- (with-directory-excursion "src/github.com/syncthing/syncthing"
- (install-file "syncthing" (string-append out "/bin")))
- (for-each (cut install-file <> (string-append utils "/bin/"))
- (find-files "bin"))
- #t)))
+ (with-directory-excursion "src/github.com/syncthing/syncthing/bin"
+ (install-file "../syncthing" (string-append out "/bin"))
+ (for-each (cut install-file <> (string-append utils "/bin/"))
+ '("stcompdirs" "stcrashreceiver"
+ "stdisco" "stdiscosrv" "stevents" "stfileinfo"
+ "stfinddevice" "stfindignored" "stgenfiles"
+ "stindex" "strelaypoolsrv" "strelaysrv" "stsigtool"
+ "stvanity" "stwatchfile" "uraggregate" "ursrv"))
+ #t))))
(add-after 'install 'install-docs
(lambda* (#:key outputs #:allow-other-keys)