aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-08-12 22:59:17 +0000
committerArun Isaac <arunisaac@systemreboot.net>2021-08-18 19:50:49 +0530
commit75e7e4e71cfe7a89d78c953bf85dbbce41869f52 (patch)
treec8b67818e8fc134f5c45e7f616520a0d1faef14e
parentd31301dfe08076e5d229175b2cd093c6fe60a6d5 (diff)
downloadguix-75e7e4e71cfe7a89d78c953bf85dbbce41869f52.tar
guix-75e7e4e71cfe7a89d78c953bf85dbbce41869f52.tar.gz
gnu: Add gcolor3.
* gnu/packages/gnome.scm (gcolor3): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 98c121ac22..37e39137e1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9978,6 +9978,38 @@ detailed properties. It is an easy way to find the character you might
only know by its Unicode name or code point.")
(license license:gpl3+))))
+(define-public gcolor3
+ (package
+ (name "gcolor3")
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/gcolor3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("libportal" ,libportal)))
+ (home-page "https://www.hjdskes.nl/projects/gcolor3/")
+ (synopsis "Simple color chooser written in GTK3")
+ (description "Color Picker is a simple color chooser written in GTK3. It
+supports both X and Wayland display servers.")
+ (license license:gpl2+)))
+
(define-public bluefish
(package
(name "bluefish")