aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-08-17 08:50:42 +0300
committerArun Isaac <arunisaac@systemreboot.net>2021-08-17 13:54:24 +0530
commit5fbeb09f911fb04dbce43282e27fce9d04d6b9b9 (patch)
treeacb8ba6c68bf9e19df64f4f8293a3d0a8250fba4
parent66cb568e311c88891de9c27bcb0f3eb658af6ae3 (diff)
downloadguix-5fbeb09f911fb04dbce43282e27fce9d04d6b9b9.tar
guix-5fbeb09f911fb04dbce43282e27fce9d04d6b9b9.tar.gz
gnu: Add go-github-com-aswinkarthik-csvdiff.
* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/golang.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 490872e886..72579d6bd2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8421,3 +8421,47 @@ zero round-trip encryption, and other advanced features.")
@url{https://github.com/Cyan4973/xxHash, xxHash} algorithm, an extremely fast
non-cryptographic hash algorithm, working at speeds close to RAM limits.")
(license license:asl2.0)))
+
+(define-public go-github-com-aswinkarthik-csvdiff
+ (package
+ (name "go-github-com-aswinkarthik-csvdiff")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aswinkarthik/csvdiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aswinkarthik/csvdiff"))
+ (propagated-inputs
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+ ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
+ ("go-github-com-spf13-afero" ,go-github-com-spf13-afero)
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
+ ("go-github-com-fatih-color" ,go-github-com-fatih-color)
+ ("go-github-com-cespare-xxhash" ,go-github-com-cespare-xxhash)
+ ("go-github-com-oneofone-xxhash" ,go-github-com-oneofone-xxhash)))
+ (home-page "https://github.com/aswinkarthik/csvdiff")
+ (synopsis "Fast diff tool for comparing CSV files")
+ (description "@code{csvdiff} is a diff tool to compute changes between two
+CSV files. It can compare CSV files with a million records in under 2
+seconds. It is specifically suited for comparing CSV files dumped from
+database tables. GNU Diff is orders of magnitude faster for comparing line by
+line. @code{csvdiff} supports
+
+@itemize
+@item Selective comparison of fields in a row
+@item Specifying group of columns as primary-key to uniquely identify a row
+@item Ignoring columns
+@item Several output formats including colored git style output or
+JSON for post-processing
+@end itemize")
+ (license license:expat)))