aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-03 21:16:41 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commit314ad6435c3999535f7461ceaeb0b32295d0b6b1 (patch)
tree92c41ecc77a7b210f8d3d88638f6529e2e7e9287
parent8e47a8e8a7fe85362b86b724443454222efa639c (diff)
downloadguix-314ad6435c3999535f7461ceaeb0b32295d0b6b1.tar
guix-314ad6435c3999535f7461ceaeb0b32295d0b6b1.tar.gz
gnu: Remove psyclpc.
As discussed in <https://bugs.gnu.org/46602>, psyclpc does not support a current release of OpenSSL. * gnu/packages/messaging.scm (psyclpc): Remove variable.
-rw-r--r--gnu/packages/messaging.scm73
1 files changed, 0 insertions, 73 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e5ecdb8894..3aa386ed6d 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1839,79 +1839,6 @@ including psyced.")
(synopsis "PSYC library in C")
(license license:agpl3+)))
-;; This commit removes the historic bundled pcre and makes psyclpc reproducible.
-(define-public psyclpc
- (let* ((commit "61cf9aa81297085e5c40170fd01221c752f8deba")
- (revision "2"))
- (package
- (name "psyclpc")
- (version (string-append "20160821-" revision "." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.psyced.org/git/psyclpc")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1viwqymbhn3cwvx0zl58rlzl5gw47zxn0ldg2nbi55ghm5zxl1z5"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; There are no tests/checks.
- #:configure-flags
- ;; If you have questions about this part, look at
- ;; "src/settings/psyced" and the ebuild.
- (list
- "--enable-use-tls=yes"
- "--enable-use-mccp" ; Mud Client Compression Protocol, leave this enabled.
- (string-append "--prefix="
- (assoc-ref %outputs "out"))
- ;; src/Makefile: Set MUD_LIB to the directory which contains
- ;; the mud data. defaults to MUD_LIB = @libdir@
- (string-append "--libdir="
- (assoc-ref %outputs "out")
- "/opt/psyced/world")
- (string-append "--bindir="
- (assoc-ref %outputs "out")
- "/opt/psyced/bin")
- ;; src/Makefile: Set ERQ_DIR to directory which contains the
- ;; stuff which ERQ can execute (hopefully) savely. Was formerly
- ;; defined in config.h. defaults to ERQ_DIR= @libexecdir@
- (string-append "--libexecdir="
- (assoc-ref %outputs "out")
- "/opt/psyced/run"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'chdir-to-src
- ;; We need to pass this as env variables
- ;; and manually change the directory.
- (lambda _
- (chdir "src")
- (setenv "CONFIG_SHELL" (which "sh"))
- (setenv "SHELL" (which "sh"))
- #t)))
- #:make-flags (list "install-all")))
- (inputs
- `(("zlib" ,zlib)
- ("openssl" ,openssl-1.0)
- ("pcre" ,pcre)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("bison" ,bison)
- ("gettext" ,gettext-minimal)
- ("help2man" ,help2man)
- ("autoconf" ,autoconf)
- ("automake" ,automake)))
- (home-page "http://lpc.psyc.eu/")
- (synopsis "psycLPC is a multi-user network server programming language")
- (description
- "LPC is a bytecode language, invented to specifically implement
-multi user virtual environments on the internet. This technology is used for
-MUDs and also the psyced implementation of the Protocol for SYnchronous
-Conferencing (PSYC). psycLPC is a fork of LDMud with some new features and
-many bug fixes.")
- (license license:gpl2))))
-
(define-public loudmouth
(package
(name "loudmouth")