aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-03 21:11:57 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:56 -0400
commit0652abcf3fde8b5e71c356bdd214454684655830 (patch)
treecbcde26715fdf7ca50133fc812fa8dae50e5a043
parentd90bb7edca6b8a780c4d1ffc78c57d20f78b364e (diff)
downloadguix-0652abcf3fde8b5e71c356bdd214454684655830.tar
guix-0652abcf3fde8b5e71c356bdd214454684655830.tar.gz
gnu: Remove pidentd.
As discussed in <https://bugs.gnu.org/46602>, pidentd does not support a current release of OpenSSL, and there does not seem to be any activity upstream to improve that. * gnu/packages/networking.scm (pidentd): Remove variable.
-rw-r--r--gnu/packages/networking.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fe5f2f2ed..ec5e383b0e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2595,33 +2595,6 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
;; distribution for clarification.
(license (list license:bsd-3 license:bsd-4))))
-(define-public pidentd
- (package
- (name "pidentd")
- (version "3.0.19")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ptrrkssn/pidentd")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1k4rr0b4ygxssbnsykzjvz4hjhazzz4j5arlilyc1iq7b1wzsk7i"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f)) ; No tests are included
- (inputs
- `(("openssl" ,openssl-1.0))) ;for the DES library
- (home-page "https://www.lysator.liu.se/~pen/pidentd/")
- (synopsis "Small Ident Daemon")
- (description
- "@dfn{Pidentd} (Peter's Ident Daemon) is an identd, which implements a
-identification server. Pidentd looks up specific TCP/IP connections and
-returns the user name and other information about the connection.")
- (license license:public-domain)))
-
(define-public spiped
(package
(name "spiped")