aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-01-27 11:33:49 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-01-27 11:36:10 +0100
commitdd1f60ecbe7e5161fe1690da5dad6232c509e32d (patch)
treef1050fbe6e62d565c5f06193c0636a09341af4c2
parentae8522d2659f6a37a2f9c9f85849d38eadec6e0c (diff)
downloadguix-dd1f60ecbe7e5161fe1690da5dad6232c509e32d.tar
guix-dd1f60ecbe7e5161fe1690da5dad6232c509e32d.tar.gz
gnu: php: Update to 7.2.1.
* gnu/packages/php.scm (php): Update to 7.2.1. [arguments]: Skip some failing tests.
-rw-r--r--gnu/packages/php.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 7c45269bb1..b9a5eb4bf2 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -52,7 +52,7 @@
(define-public php
(package
(name "php")
- (version "7.1.12")
+ (version "7.2.1")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -60,7 +60,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1czflr5wb2f7pmgdc1vxy1kcln5rlkkly2z3skrb2wa5fx88h4d0"))
+ "08l8zmp8wbavq6wlgx19irz59csb44jhbsr172bfsq36v8pzhv3c"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -271,12 +271,25 @@
;; ("ISO-8859-1"=>"UTF-8") unknown error.
"ext/standard/tests/file/bug43008.phpt"
;; Table data not created in sqlite(?).
- "ext/pdo_sqlite/tests/bug_42589.phpt"))
+ "ext/pdo_sqlite/tests/bug_42589.phpt"
+
+ ;; Small variation in output.
+ "ext/mbstring/tests/mb_ereg_variation3.phpt"
+ "ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
+ "ext/mbstring/tests/bug72994.phpt"
+ "ext/ldap/tests/ldap_set_option_error.phpt"
+
+ ;; XXX: This is CVE-2018-5711. There is no fix yet in libgd.
+ ;; See https://github.com/libgd/libgd/issues/420
+ "ext/gd/tests/bug75571.phpt"))
;; Skip tests requiring network access.
(setenv "SKIP_ONLINE_TESTS" "1")
;; Without this variable, 'make test' passes regardless of failures.
(setenv "REPORT_EXIT_STATUS" "1")
+ ;; Skip tests requiring I/O facilities that are unavailable in the
+ ;; build environment
+ (setenv "SKIP_IO_CAPTURE_TESTS" "1")
#t)))
#:test-target "test"))
(inputs