aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:52:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 00:09:18 +0100
commitcb3909256d42b304cc8f1705d43d98ebeee3f6ad (patch)
treebcc7466fc61bfc80fe50b6d3273fc8c7b7d4be97
parent98a11b7fcea74225c1b35e7f28631d7d22133388 (diff)
downloadguix-cb3909256d42b304cc8f1705d43d98ebeee3f6ad.tar
guix-cb3909256d42b304cc8f1705d43d98ebeee3f6ad.tar.gz
gnu: Add msitools.
* gnu/packages/package-management.scm (msitools): New public variable.
-rw-r--r--gnu/packages/package-management.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index ced7642ce0..a890dca403 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -35,10 +35,12 @@
#:use-module (gnu packages file)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages man)
#:use-module (gnu packages nettle)
@@ -56,6 +58,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages vim)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xml)
#:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -830,3 +833,31 @@ on top of GNU Guix.")
Microsoft cabinet (.@dfn{CAB}) files.")
(license (list license:gpl2+ ; tests/testsuite.at
license:lgpl2.1+)))) ; the rest
+
+(define-public msitools
+ (package
+ (name "msitools")
+ (version "0.97")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0pn6izlgwi4ngpk9jk2n38gcjjpk29nm15aad89bg9z3k9n2hnrs"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gcab" ,gcab)
+ ("glib" ,glib)
+ ("libgsf" ,libgsf)
+ ("libxml2" ,libxml2)
+ ("uuid" ,util-linux)))
+ (home-page "https://wiki.gnome.org/msitools")
+ (synopsis "Windows Installer file manipulation tool")
+ (description
+ "msitools is a collection of command-line tools to inspect, extract, build,
+and sign Windows@tie{}Installer (.@dfn{MSI}) files. It aims to be a solution
+for packaging and deployment of cross-compiled Windows applications.")
+ (license license:lgpl2.1+)))