aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-01-21 19:31:16 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:28:27 +0100
commita893dc2f484f89d9f0ba21d44bdac3b792872781 (patch)
tree02b7f150e13f6a5baf3dfea9f7919dc5e36579b3
parent6055e88c0d6212884d5f050eea1cefc4fcaec043 (diff)
downloadguix-a893dc2f484f89d9f0ba21d44bdac3b792872781.tar
guix-a893dc2f484f89d9f0ba21d44bdac3b792872781.tar.gz
gnu: rct: Add missing headers, enable RTTI.
* gnu/packages/patches/rct-add-missing-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/cpp.scm (rct): Use the patch, enable RTTI. [source]: Use the patch to add missing headers from installation. [arguments]: Enable RTTI in configure-flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cpp.scm6
-rw-r--r--gnu/packages/patches/rct-add-missing-headers.patch43
3 files changed, 48 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 240554fe4e..65369bc609 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1054,6 +1054,7 @@ dist_patch_DATA = \
%D%/packages/patches/raptor2-heap-overflow.patch \
%D%/packages/patches/ratpoison-shell.patch \
%D%/packages/patches/rcs-5.9.4-noreturn.patch \
+ %D%/packages/patches/rct-add-missing-headers.patch \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/readline-7.0-mingw.patch \
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7f711d5542..95e82fcb61 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -68,7 +68,7 @@ operating system functions.")
(define-public rct
(let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
- (revision "1")
+ (revision "2")
(version (git-version "0.0.0" revision commit)))
(package
(name "rct")
@@ -82,11 +82,13 @@ operating system functions.")
(sha256
(base32
"1m2931jacka27ghnpgf1z1plkkr64z0pga4r4zdrfpp2d7xnrdvb"))
+ (patches (search-patches "rct-add-missing-headers.patch"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DWITH_TESTS=ON"))) ; To run the test suite
+ '("-DWITH_TESTS=ON" ; To run the test suite
+ "-DRCT_RTTI_ENABLED=ON")))
(native-inputs
`(("cppunit" ,cppunit)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/rct-add-missing-headers.patch b/gnu/packages/patches/rct-add-missing-headers.patch
new file mode 100644
index 0000000000..4d133aa249
--- /dev/null
+++ b/gnu/packages/patches/rct-add-missing-headers.patch
@@ -0,0 +1,43 @@
+From: fis <ybbs.daans@hotmail.com>
+Date: Sat, 20 Jan 2018 07:42:38 +0800
+Subject: [PATCH] rct.cmake: Add missing headers.
+
+---
+ rct.cmake | 20 ++++++++++++++++++++
+ 1 file changed, 20 insertions(+)
+
+diff --git a/rct.cmake b/rct.cmake
+index 323e7b9..3e0ac6b 100644
+--- a/rct.cmake
++++ b/rct.cmake
+@@ -339,7 +339,27 @@ if (NOT RCT_NO_INSTALL)
+ rct/Timer.h
+ rct/Value.h
+ rct/WriteLocker.h
++ rct/CpuUsage.h
++ rct/DataFile.h
++ rct/Date.h
++ rct/EmbeddedLinkedList.h
++ rct/FinishMessage.h
++ rct/Flags.h
++ rct/Hash.h
++ rct/LinkedList.h
++ rct/Map.h
++ rct/MemoryMappedFile.h
++ rct/OnDestruction.h
++ rct/QuitMessage.h
++ rct/ResponseMessage.h
++ rct/ScriptEngine.h
++ rct/StackBuffer.h
++ rct/WindowsUnicodeConversion.h
+ DESTINATION include/rct)
+
++ install(FILES
++ json/json.hpp
++ DESTINATION include/rct/json)
++
+ install(EXPORT "rct" DESTINATION lib/cmake)
+ endif ()
+--
+2.13.6
+