aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:52:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 00:09:18 +0100
commit98a11b7fcea74225c1b35e7f28631d7d22133388 (patch)
tree60d24d25b85417278dfdede3da9fb3a5850d1558
parentca4c7d4cd44b14b98c8b142c98a80dadd98635d5 (diff)
downloadguix-98a11b7fcea74225c1b35e7f28631d7d22133388.tar
guix-98a11b7fcea74225c1b35e7f28631d7d22133388.tar.gz
gnu: Add gcab.
* gnu/packages/package-management.scm (gcab): New public variable.
-rw-r--r--gnu/packages/package-management.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 782d336eea..ced7642ce0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages file)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages graphviz)
@@ -803,3 +804,29 @@ on top of GNU Guix.")
;; the web interface modules in gwl/ are licensed AGPL3+,
;; and the fonts included in this package are licensed OFL1.1.
(license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
+
+(define-public gcab
+ (package
+ (name "gcab")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1vxdsiky3492zlyrym02sdwf09y19rl2z5h5iin7qm0wizw5wvm1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("zlib" ,zlib)))
+ (home-page "https://wiki.gnome.org/msitools") ; no dedicated home page
+ (synopsis "Microsoft Cabinet file manipulation library")
+ (description
+ "The libgcab library provides GObject functions to read, write, and modify
+Microsoft cabinet (.@dfn{CAB}) files.")
+ (license (list license:gpl2+ ; tests/testsuite.at
+ license:lgpl2.1+)))) ; the rest