aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-24 06:35:29 -0500
committerMark H Weaver <mhw@netris.org>2018-01-24 06:35:29 -0500
commit76c7fc436a151236f5e1ff966fd99172d85ee422 (patch)
tree598b72a4586a5e1d12149483059f2c1e0a2b9892
parenta6af4d25f1af0acd4fa26b69c5fd0bd3042a85e2 (diff)
downloadguix-76c7fc436a151236f5e1ff966fd99172d85ee422.tar
guix-76c7fc436a151236f5e1ff966fd99172d85ee422.tar.gz
gnu: python-qscintilla: Remove result code plumbing.
* gnu/packages/qt.scm (python-qscintilla)[arguments]: In the 'configure' phase, remove result code plumbing that is no longer needed, since 'invoke' never returns #false.
-rw-r--r--gnu/packages/qt.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 596006080a..34938b9c02 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1715,15 +1715,14 @@ indicators, code completion and call tips.")
(replace 'configure
(lambda* (#:key outputs configure-flags #:allow-other-keys)
(chdir "Python")
- (and (apply invoke "python3" "configure.py"
- configure-flags)
- ;; Install to the right directory
- (begin
- (substitute* '("Makefile"
- "Qsci/Makefile")
- (("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+")
- (assoc-ref outputs "out")))
- #t)))))))
+ (apply invoke "python3" "configure.py"
+ configure-flags)
+ ;; Install to the right directory
+ (substitute* '("Makefile"
+ "Qsci/Makefile")
+ (("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+")
+ (assoc-ref outputs "out")))
+ #t)))))
(inputs
`(("qscintilla" ,qscintilla)
("python" ,python)