aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-01-21 18:37:57 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:22:00 +0100
commit6055e88c0d6212884d5f050eea1cefc4fcaec043 (patch)
treee31301773e488f8a995c5a3d1a941f8bc26fe8e0
parentbfe88e0c6e8e6f548810ce937170a5e5c560b368 (diff)
downloadguix-6055e88c0d6212884d5f050eea1cefc4fcaec043.tar
guix-6055e88c0d6212884d5f050eea1cefc4fcaec043.tar.gz
gnu: Add python-yapf.
* gnu/packages/python.scm (python-yapf, python2-yapf): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2c2a0fde3b..8802abd094 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12393,3 +12394,26 @@ and works only with Python 2 and NumPy < 1.9.")
(define-public python2-phonenumbers
(package-with-python2 python-phonenumbers))
+
+(define-public python-yapf
+ (package
+ (name "python-yapf")
+ (version "0.20.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "yapf" version))
+ (sha256
+ (base32
+ "0s7l6afzxvpx39kzd0lwshlaxw8m4fwh4iy0rlmav4vipr3g46dx"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/google/yapf")
+ (synopsis "Formatter for Python code")
+ (description "YAPF is a formatter for Python code. It's based off of
+@dfn{clang-format}, developed by Daniel Jasper. In essence, the algorithm
+takes the code and reformats it to the best formatting that conforms to the
+style guide, even if the original code didn't violate the style guide.")
+ (license license:asl2.0)))
+
+(define-public python2-yapf
+ (package-with-python2 python-yapf))