aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-01-22 15:48:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-22 22:49:15 +0100
commit555773932d6391aaf2285cbfdc9b4b99f86d4c19 (patch)
treec3aefddfca4e6b6e2360f8551c807ed2aac11a63
parent625cdc3fdeb16c422db8967e7bf7f4bcb424821e (diff)
downloadguix-555773932d6391aaf2285cbfdc9b4b99f86d4c19.tar
guix-555773932d6391aaf2285cbfdc9b4b99f86d4c19.tar.gz
gnu: Add r-argparser.
* gnu/packages/cran.scm (r-argparser): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 62dc6a9bd7..cb39772ae5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1840,3 +1840,24 @@ plots in @code{ggplot2}.")
attractive command line interfaces (CLIs). It includes tools for drawing
rules, boxes, trees, and Unicode symbols with ASCII alternatives.")
(license license:expat)))
+
+(define-public r-argparser
+ (package
+ (name "r-argparser")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "argparser" version))
+ (sha256
+ (base32
+ "0s1wxshx4jk69wfxhycx973q6y8cmqrfymyjklhq1i8xrj0kmmx9"))))
+ (build-system r-build-system)
+ (home-page "https://bitbucket.org/djhshih/argparser")
+ (synopsis "Command-line argument parser")
+ (description
+ "This package provides a cross-platform command-line argument parser
+written purely in R with no external dependencies. It is useful with the
+Rscript front-end and facilitates turning an R script into an executable
+script.")
+ (license license:gpl3+)))