aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2018-01-22 19:24:20 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-22 19:52:33 +0100
commit3da86c52e59040523f2df1d8a57ac96ff3493aed (patch)
treed89c608967f30f63ff92dbbcf035a4574b358f44
parent0a92ebdeeb8d147badea2bc96352767290c2d30e (diff)
downloadguix-3da86c52e59040523f2df1d8a57ac96ff3493aed.tar
guix-3da86c52e59040523f2df1d8a57ac96ff3493aed.tar.gz
gnu: Add python-stdnum.
* gnu/packages/finance.scm (python-stdnum, python2-stdnum): New variables. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/finance.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ce0172be06..c93f641933 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -720,3 +721,34 @@ agent.")
(description "This package allows using KeepKey as a hardware SSH/GPG
agent.")
(license license:lgpl3)))
+
+(define-public python-stdnum
+ (package
+ (name "python-stdnum")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-stdnum" version))
+ (sha256
+ (base32
+ "0hvr47q32xbyiznpmbg4r8rcvxhnf0lwf33hcpnynyik57djy5np"))))
+ (build-system python-build-system)
+ (home-page
+ "https://arthurdejong.org/python-stdnum/")
+ (synopsis
+ "Python module to handle standardized number and code formats")
+ (description
+ "This is a Python library that aims to provide functions to handle,
+parse and validate standard numbers.
+The module supports more than 100 different number formats
+amongst which a great number of VAT and other tax numbers,
+personal identity and company identification codes,
+international standard numbers (ISBN, IBAN, EAN, etc.)
+and various other formats.
+The module also inclused implementations of the Verhoeff,
+Luhn and family of ISO/IEC 7064 check digit algorithms. ")
+ (license license:lgpl2.1+)))
+
+(define-public python2-stdnum
+ (package-with-python2 python-stdnum))