aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:52:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 00:09:18 +0100
commit318bc42946af13e20dc6e4ec4b3e526f68de48f7 (patch)
tree6e97cc7e884bfee5bd696c040e935f71162657d3
parentcb3909256d42b304cc8f1705d43d98ebeee3f6ad (diff)
downloadguix-318bc42946af13e20dc6e4ec4b3e526f68de48f7.tar
guix-318bc42946af13e20dc6e4ec4b3e526f68de48f7.tar.gz
gnu: appstream-glib: Update to 0.7.4.
* gnu/packages/glib.scm (appstream-glib): Update to 0.7.4. [build-system]: Switch to meson-build-system. [native-inputs]: Add gettext and glib:bin. [inputs]: Add gcab, gperf, and libyaml. Remove nettle. [arguments]: Adapt #:configure-flags to new build system. Patch fewer tests in ‘patch-tests’ phase.
-rw-r--r--gnu/packages/glib.scm30
1 files changed, 20 insertions, 10 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 3b818164dc..5b1d203e9d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,19 +36,23 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
#:use-module (gnu packages nettle)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix download)
@@ -714,7 +719,7 @@ programming langauage. It also contains the utility
(define-public appstream-glib
(package
(name "appstream-glib")
- (version "0.6.7")
+ (version "0.7.4")
(source (origin
(method url-fetch)
(uri (string-append "https://people.freedesktop.org/~hughsient/"
@@ -722,30 +727,35 @@ programming langauage. It also contains the utility
"appstream-glib-" version ".tar.xz"))
(sha256
(base32
- "08mrf4k0jhnpdd4fig2grmi2vbxkgdhrwk0d0zq0j1wp5ip7arwp"))))
- (build-system gnu-build-system)
+ "09f8lq8nkr3gaws7fc3pzyz12lhz771l1p7lv8ni8z1gi470r7d0"))))
+ (build-system meson-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("pkg-config" ,pkg-config)))
(inputs
`(("gdk-pixbuf" ,gdk-pixbuf)
+ ("gcab" ,gcab)
("glib" ,glib)
+ ("gperf" ,gperf)
("gtk+" ,gtk+)
("json-glib" ,json-glib)
("libarchive" ,libarchive)
("libsoup" ,libsoup)
- ("nettle" ,nettle)
- ("util-linux" ,util-linux)))
+ ("libyaml" ,libyaml)
+ ("util-linux" ,util-linux))) ; for libuuid
(arguments
`(#:configure-flags
- '("--disable-firmware" "--disable-dep11")
+ (list "-Denable-dep11=false"
+ "-Denable-introspection=false" ; avoid g-ir-scanner dependency
+ "-Denable-rpm=false"
+ "-Denable-stemmer=false")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-tests
(lambda _
(substitute* "libappstream-glib/as-self-test.c"
- (("g_test_add_func.*as_test_store_local_appdata_func);") "")
- (("g_test_add_func.*as_test_store_speed_appdata_func);") "")
- (("g_test_add_func.*as_test_store_speed_desktop_func);") ""))
+ (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
#t)))))
(home-page "https://github.com/hughsie/appstream-glib")
(synopsis "Library for reading and writing AppStream metadata")