aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-21 14:15:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-24 13:19:08 +0100
commit26b388cead0bebb86b50b9cfbc8fbc8661b4811b (patch)
tree6ada8217a77f9ce28d14dc953bc41963c5bfde51
parenta204c14cb587e536870c5294d0536755a2bcb68e (diff)
downloadguix-26b388cead0bebb86b50b9cfbc8fbc8661b4811b.tar
guix-26b388cead0bebb86b50b9cfbc8fbc8661b4811b.tar.gz
gnu: Add emacs-circe.
* gnu/packages/emacs.scm (emacs-circe): New variable.
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ce4c764708..590ea802c4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6546,6 +6546,33 @@ needs to be refreshed, the code handles it automatically and stores the new
value of the access token.")
(license license:gpl3+)))
+(define-public emacs-circe
+ (package
+ (name "emacs-circe")
+ (version "2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jorgenschaefer/circe.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "19h3983zy3f15cgs86irvbdzz55qyjm48qd7gjlzcxplr7vnnh0j"))))
+ (build-system emacs-build-system)
+ ;; In order to securely connect to an IRC server using TLS, Circe requires
+ ;; the GnuTLS binary.
+ (propagated-inputs
+ `(("gnutls" ,gnutls)))
+ (home-page "https://github.com/jorgenschaefer/circe")
+ (synopsis "Client for IRC in Emacs")
+ (description "Circe is a Client for IRC in Emacs. It integrates well with
+the rest of the editor, using standard Emacs key bindings and indicating
+activity in channels in the status bar so it stays out of your way unless you
+want to use it.")
+ (license license:gpl3+)))
+
(define-public emacs-bash-completion
(package
(name "emacs-bash-completion")