aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-25 02:03:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 00:09:19 +0100
commit218b94f3b8c5a01cd348b125c8d8dcd66225a220 (patch)
tree184ab2b1ae1529e47041d3f145d5fa1f73492bac
parente80611c4550577d7ce0578d79dafe479f8350289 (diff)
downloadguix-218b94f3b8c5a01cd348b125c8d8dcd66225a220.tar
guix-218b94f3b8c5a01cd348b125c8d8dcd66225a220.tar.gz
gnu: reposurgeon: Update to 3.43.
* gnu/packages/version-control.scm (reposurgeon): Update to 3.43. [source]: Add a patch needed to build the package. [arguments]: Add ‘patch-inputs’ phase. [native-inputs]: Replace docbook-xml-4.1.2 with the latest docbook-xml. [inputs]: Add tzdata. * gnu/packages/patches/reposurgeon-add-missing-docbook-files.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/reposurgeon-add-missing-docbook-files.patch22
-rw-r--r--gnu/packages/version-control.scm20
3 files changed, 38 insertions, 5 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index fae837ddaf..80d6a8d4c4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1058,6 +1058,7 @@ dist_patch_DATA = \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/readline-7.0-mingw.patch \
+ %D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
%D%/packages/patches/reptyr-fix-gcc-7.patch \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
diff --git a/gnu/packages/patches/reposurgeon-add-missing-docbook-files.patch b/gnu/packages/patches/reposurgeon-add-missing-docbook-files.patch
new file mode 100644
index 0000000000..707d032744
--- /dev/null
+++ b/gnu/packages/patches/reposurgeon-add-missing-docbook-files.patch
@@ -0,0 +1,22 @@
+Author: Tobias Geerinckx-Rice <me@tobias.gr>
+Upstream issue: <https://gitlab.com/esr/reposurgeon/merge_requests/101>
+
+Two files required to build the documentation (including man pages) are
+not included in the latest reposurgeon release, breaking ‘make all’.
+
+Luckily, they are tiny:
+
+--- a/docbook-extra.xml 1970-01-01 01:00:00.000000000 +0100
++++ b/docbook-extra.xml 2018-01-25 00:17:18.236727017 +0100
+@@ -0,0 +1,5 @@
++<?xml version='1.0'?>
++<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
++<xsl:param name="variablelist.term.separator"></xsl:param>
++<xsl:param name="variablelist.term.break.after">1</xsl:param>
++</xsl:stylesheet>
+diff -Naur reposurgeon-3.43/nofooter.conf reposurgeon-3.43-b/nofooter.conf
+--- a/nofooter.conf 1970-01-01 01:00:00.000000000 +0100
++++ b/nofooter.conf 2018-01-25 00:23:15.384498847 +0100
+@@ -0,0 +1,2 @@
++[footer-text]
++
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 976849b184..ded181e8ab 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 André <eu@euandre.org>
@@ -1318,14 +1318,16 @@ any project with more than one developer, is one of Aegis's major functions.")
(define-public reposurgeon
(package
(name "reposurgeon")
- (version "3.37")
+ (version "3.43")
(source (origin
(method url-fetch)
(uri (string-append "http://www.catb.org/~esr/" name "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "14asjg4xy3mhh5z0r3k7c1wv9y803j2zfq32g5q5m95sf7yzygan"))))
+ "1af0z14wcm4bk5a9ysinbwq2fp3lf5f7i8mvwh7286hr3fnagcaz"))
+ (patches (search-patches
+ "reposurgeon-add-missing-docbook-files.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no test suite distributed
@@ -1333,6 +1335,13 @@ any project with more than one developer, is one of Aegis's major functions.")
(list (string-append "target=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tzdata (assoc-ref inputs "tzdata")))
+ (substitute* "reposurgeon"
+ (("/usr/share/zoneinfo")
+ (string-append tzdata "/share/zoneinfo")))
+ #t)))
(delete 'configure)
(add-before 'build 'fix-docbook
(lambda* (#:key inputs #:allow-other-keys)
@@ -1347,10 +1356,11 @@ any project with more than one developer, is one of Aegis's major functions.")
(string-append (assoc-ref outputs "out")
"/share/emacs/site-lisp")))))))
(inputs
- `(("python" ,python-wrapper)))
+ `(("python" ,python-wrapper)
+ ("tzdata" ,tzdata)))
(native-inputs
`(("asciidoc" ,asciidoc)
- ("docbook-xml" ,docbook-xml-4.1.2)
+ ("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
("libxml2" ,libxml2)
("xmlto" ,xmlto)))