aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 20:51:02 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commitee1f51011c9334dae369435d91f65322408806b9 (patch)
tree48d934806b701b11ddab670d8abde37d6cfcc46c
parenta4fd4db6d12a6aaa37984774a1043f234fb41c42 (diff)
downloadguix-ee1f51011c9334dae369435d91f65322408806b9.tar
guix-ee1f51011c9334dae369435d91f65322408806b9.tar.gz
gnu: python-autopage: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-autopage)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 75b99086d0..034781c2fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -259,6 +259,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1)
@@ -7127,33 +7128,16 @@ run simple @code{argparse} parsers from function signatures.")
(sha256
(base32
"169ixll1ncm2a2pcc86665ikjv2lrzs10p6c1w4yj55p3gk3xgh1"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; Do a manual PEP 517 style build/install procedure until the
- ;; python-build-system overhaul is merged.
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (let ((circa-1980 (* 10 366 24 60 60)))
- (setenv "SOURCE_DATE_EPOCH" (number->string circa-1980))
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" "."))))
(add-before 'check 'disable-e2e-tests
(lambda _
;; These tests rely on KeyboardInterrupts which do not
;; work in the build container.
- (delete-file "autopage/tests/test_end_to_end.py")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"))))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
+ (delete-file "autopage/tests/test_end_to_end.py"))))))
(native-inputs
(list python-pypa-build
python-setuptools