aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:44:31 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commite05e2a7a75fb7994df48423ecebb7bf1a6ea8177 (patch)
treed77730d95b0bed44434f810a121aababe1e8f9c8
parentb8efe89eb4f569d3140e3feb398eb2f78b8987b6 (diff)
downloadguix-e05e2a7a75fb7994df48423ecebb7bf1a6ea8177.tar
guix-e05e2a7a75fb7994df48423ecebb7bf1a6ea8177.tar.gz
gnu: python-pygmsh: Use pyproject-build-system.
* gnu/packages/simulation.scm (python-pygmsh)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/simulation.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 9e6ef4ada3..256e404970 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -63,6 +63,7 @@
#:use-module (guix svn-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -835,7 +836,7 @@ tools and a collection of Python modules for programmatic use.")
(sha256
(base32
"11flp2c4ynk1fhanf4mqyzrpd0gjbnv6afrwwc7xi3mb6ms69lr0"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -845,21 +846,8 @@ tools and a collection of Python modules for programmatic use.")
;; Due to lack of metadata, the gmsh Python package is not
;; detected although importable.
(substitute* "pyproject.toml"
- (("\"gmsh\",") ""))))
- ;; XXX: PEP 517 manual build copied from python-isort.
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v" "tests"))))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
- (native-inputs (list python-pypa-build python-flit-core python-pytest))
+ (("\"gmsh\",") "")))))))
+ (native-inputs (list python-flit-core python-pytest))
(propagated-inputs (list gmsh python-meshio python-numpy))
(home-page "https://github.com/nschloe/pygmsh")
(synopsis "Python frontend for Gmsh")