aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-04-23 11:07:58 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:06 +0200
commitc485a9d8af210425a0435280fff8588563e49684 (patch)
tree2808afa7226bfb9c1a52633d92b8d37acfcebdf5
parentcae327a3b0507cc2d0d69c9c1abf4ec8c45c92e8 (diff)
downloadguix-c485a9d8af210425a0435280fff8588563e49684.tar
guix-c485a9d8af210425a0435280fff8588563e49684.tar.gz
gnu: python-setuptools: Move to python-build.
* gnu/packages/python-xyz.scm (python-setuptools): Move… * gnu/packages/python-build.scm: …here. * gnu/packages/chemistry.scm, gnu/packages/messaging.scm, gnu/packages/sequoia.scm, tests/lint.scm: Adjust module imports accordingly. Co-authored-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/chemistry.scm1
-rw-r--r--gnu/packages/messaging.scm1
-rw-r--r--gnu/packages/python-build.scm39
-rw-r--r--gnu/packages/python-xyz.scm40
-rw-r--r--gnu/packages/sequoia.scm2
-rw-r--r--tests/lint.scm2
6 files changed, 43 insertions, 42 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index d0582c4b6f..6549da3453 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index fa889d24a7..86d9914c90 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -116,6 +116,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 9d9b07f769..7572bc5ce3 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -41,6 +41,45 @@
;;;
;;; Code:
+(define-public python-setuptools
+ (package
+ (name "python-setuptools")
+ (version "64.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "setuptools" version))
+ (sha256
+ (base32
+ "1sllqf0bhsl2yilf1w0xnlz0r4yaksmwaj0ap91zdc6kgbigdjiv"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; TODO: setuptools now bundles the following libraries:
+ ;; packaging, pyparsing, six and appdirs. How to unbundle?
+ ;; Remove included binaries which are used to build self-extracting
+ ;; installers for Windows.
+ '(for-each delete-file (find-files "setuptools"
+ "^(cli|gui).*\\.exe$")))))
+ (build-system python-build-system)
+ ;; FIXME: Tests require pytest, which itself relies on setuptools.
+ ;; One could bootstrap with an internal untested setuptools.
+ (arguments (list #:tests? #f))
+ (home-page "https://pypi.org/project/setuptools/")
+ (synopsis "Library designed to facilitate packaging Python projects")
+ (description "Setuptools is a fully-featured, stable library designed to
+facilitate packaging Python projects, where packaging includes:
+@itemize
+@item Python package and module definitions
+@item distribution package metadata
+@item test hooks
+@item project installation
+@item platform-specific details.
+@end itemize")
+ (license (list license:psfl ;setuptools itself
+ license:expat ;six, appdirs, pyparsing
+ license:asl2.0 ;packaging is dual ASL2/BSD-2
+ license:bsd-2))))
+
(define-public python-wheel
(package
(name "python-wheel")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd03b78e93..27dbbd831d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2178,46 +2178,6 @@ Because only safe literals are encoded, it is safe to send serpent data to
other machines, such as over the network.")
(license license:expat)))
-(define-public python-setuptools
- (package
- (name "python-setuptools")
- (version "64.0.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "setuptools" version))
- (sha256
- (base32
- "1sllqf0bhsl2yilf1w0xnlz0r4yaksmwaj0ap91zdc6kgbigdjiv"))
- (modules '((guix build utils)))
- (snippet
- ;; Remove included binaries which are used to build self-extracting
- ;; installers for Windows.
- ;; TODO: Find some way to build them ourself so we can include them.
- '(for-each delete-file (find-files "setuptools"
- "^(cli|gui).*\\.exe$")))))
- (build-system python-build-system)
- ;; FIXME: Tests require pytest, which itself relies on setuptools.
- ;; One could bootstrap with an internal untested setuptools.
- (arguments (list #:tests? #f))
- (home-page "https://pypi.org/project/setuptools/")
- (synopsis "Library designed to facilitate packaging Python projects")
- (description "Setuptools is a fully-featured, stable library designed to
-facilitate packaging Python projects, where packaging includes:
-@itemize
-@item Python package and module definitions
-@item distribution package metadata
-@item test hooks
-@item project installation
-@item platform-specific details.
-@end itemize")
- ;; TODO: setuptools now bundles the following libraries:
- ;; packaging, pyparsing, six and appdirs. How to unbundle?
- (license (list license:psfl ;setuptools itself
- license:expat ;six, appdirs, pyparsing
- license:asl2.0 ;packaging is dual ASL2/BSD-2
- license:bsd-2))))
-
(define-public python-setuptools-declarative-requirements
(package
(name "python-setuptools-declarative-requirements")
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index a8d21ac1a4..7002f684b8 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -36,7 +36,7 @@
#:use-module (gnu packages nettle)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz) ;; python-setuptools
+ #:use-module (gnu packages python-build) ;python-setuptools
#:use-module (gnu packages rust)
#:use-module (gnu packages tls))
diff --git a/tests/lint.scm b/tests/lint.scm
index b848e32aee..ce22e2355a 100644
--- a/tests/lint.scm
+++ b/tests/lint.scm
@@ -50,7 +50,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-build)
#:use-module ((gnu packages bash) #:select (bash bash-minimal))
#:use-module (web uri)
#:use-module (web server)