aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-21 00:37:06 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:08 +0200
commit9ffbcb8a0661cfb5ce05047c196865c5b81a61b0 (patch)
treea7a99bf1a45ee420b64546c601401d4f332b1468
parentd2e88c383b84ef84efcab3a32af013c80a117ccd (diff)
downloadguix-9ffbcb8a0661cfb5ce05047c196865c5b81a61b0.tar
guix-9ffbcb8a0661cfb5ce05047c196865c5b81a61b0.tar.gz
gnu: python-cattrs: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-cattrs)[build-system]: Set to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove obsolete phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7fa8974c74..2a9ee38950 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17213,12 +17213,11 @@ strings require only one extra byte in addition to the strings themselves.")
(sha256
(base32
"1n0h25gj6zd02kqyl040xpdvg4hpy1j92716sz0rg019xjqqijqb"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: PEP 517 manual build copied from python-isort.
(add-after 'unpack 'adjust-for-older-attrs
;; Our older attrs package is using the 'attr' rather than 'attrs'
;; namespace.
@@ -17227,14 +17226,6 @@ strings require only one extra byte in addition to the strings themselves.")
(substitute* (find-files "." "\\.py$")
(("from attrs\\b")
"from attr"))))
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -17252,7 +17243,6 @@ strings require only one extra byte in addition to the strings themselves.")
python-msgpack
python-poetry-core
python-pymongo ;for the bson module
- python-pypa-build
python-pytest
python-pytest-xdist))
(propagated-inputs