aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:34:31 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commit8bdc4c15474e226d1bc7e07ce6f4228a7b3317a5 (patch)
tree6bc9a98cde86e7fa14d1bd799677d0c6a5ca5d3c
parenteecc807ea4c8ea6735c42375fd2f859b56f0d338 (diff)
downloadguix-8bdc4c15474e226d1bc7e07ce6f4228a7b3317a5.tar
guix-8bdc4c15474e226d1bc7e07ce6f4228a7b3317a5.tar.gz
gnu: python-mypy-protobuf: Switch to pyproject-build-system.
* gnu/packages/protobuf.scm (python-mypy-protobuf)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/protobuf.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index a61d9d7492..e90e0ad3fa 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -31,6 +31,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system emacs)
#:use-module (guix build-system ruby)
@@ -285,22 +286,11 @@ any memory-restricted system.")
(sha256
(base32
"0z03h9k68qvnlyhpk0ndwp01bdx77vrjr6mybxq4ldilkkbksklk"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: PEP 517 manual build copied from python-isort.
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
(add-before 'check 'generate-protos-for-tests
(lambda _
;; Generate Python sources.
@@ -324,7 +314,6 @@ any memory-restricted system.")
(native-inputs
(list python-grpc-stubs
python-grpcio-tools
- python-pypa-build
python-pytest
python-typing-extensions-next))
(propagated-inputs