aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-21 00:15:23 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:08 +0200
commit5e17453f189a7cb2958d50774e4e50686f0b6442 (patch)
tree4fdf0562601eaa553eb224677530b5d9a9dea025
parent3c685772deb56010803e0f5d4d2d10f1b7a24064 (diff)
downloadguix-5e17453f189a7cb2958d50774e4e50686f0b6442.tar
guix-5e17453f189a7cb2958d50774e4e50686f0b6442.tar.gz
gnu: python-openapi-spec-validator: Use pyproject-build-system.
* gnu/packages/python-web.scm (python-openapi-spec-validator)[build-system]: Set to PYPROJECT-BUILD-SYSTEM. [arguments]: Add #:test-flags. Remove obsolete phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 6 insertions, 20 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 370245de3a..cbc515fc64 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1643,33 +1643,19 @@ JSON Schema Specification Draft 2020-12.
(sha256
(base32
"1q09sjh4hsc0c8yqbd97h5mp6rwh427y6zyn8kv8wljk6sa0fs4q"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
+ ;; The example tests attempt to fetch resources from the Internet
+ ;; (see: https://github.com/p1c2u/openapi-spec-validator/issues/151).
+ #:test-flags #~'("-vv" "-k" "not Example and not Exampe")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-coverage-pytest-options
(lambda _
(substitute* "pyproject.toml"
- (("^--cov.*") ""))))
- ;; XXX: PEP 517 manual build copied from python-isort.
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- ;; The example tests attempt to fetch resources from
- ;; the Internet (see:
- ;; https://github.com/p1c2u/openapi-spec-validator/issues/151).
- "-k" "not Example and not Exampe"))))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
- (native-inputs (list python-poetry-core python-pypa-build python-pytest))
+ (("^--cov.*") "")))))))
+ (native-inputs (list python-poetry-core python-pytest))
(propagated-inputs
(list python-jsonschema
python-openapi-schema-validator