aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:02:11 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commit4c8e0b32745c952bbfb9196f680003b7e1753bbf (patch)
tree81026cb29db635c7b111eb18c7f7a20239bad192
parentee1f51011c9334dae369435d91f65322408806b9 (diff)
downloadguix-4c8e0b32745c952bbfb9196f680003b7e1753bbf.tar
guix-4c8e0b32745c952bbfb9196f680003b7e1753bbf.tar.gz
gnu: python-pydyf: Use pyproject-build-system.
* gnu/packages/pdf.scm (python-pydyf)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove #:phases. Add #:test-flags. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/pdf.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index c6f1e952f9..9e809a8382 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -49,6 +49,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
@@ -735,28 +736,14 @@ extracting content or merging files.")
(uri (pypi-uri "pydyf" version))
(sha256
(base32 "18q43g5d9455msipcgd5fvnh8m4a2rz189slzfg80yycjw66rshs"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-c" "/dev/null")))))))
+ #:test-flags #~'("-vv" "-c" "/dev/null")))
(propagated-inputs (list python-pillow))
(native-inputs
(list ghostscript
python-flit-core
- python-pypa-build
python-pytest))
(home-page "https://github.com/CourtBouillon/pydyf")
(synopsis "Low-level PDF generator")