aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-21 00:12:03 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:08 +0200
commit3c685772deb56010803e0f5d4d2d10f1b7a24064 (patch)
tree6db25f2c6826b2dc98cd1532945c0525ada464d5
parent7b499ef1168784b6288c423846e84939f08de0c3 (diff)
downloadguix-3c685772deb56010803e0f5d4d2d10f1b7a24064.tar
guix-3c685772deb56010803e0f5d4d2d10f1b7a24064.tar.gz
gnu: python-openapi-schema-validator: Use pyproject-build-system.
* gnu/packages/python-web.scm (python-openapi-schema-validator)[build-system]: Set to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f5625cc305..370245de3a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -79,6 +79,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system copy)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix gexp)
#:use-module (guix utils)
@@ -1601,7 +1602,7 @@ is Python’s.")
(sha256
(base32
"1swm8h74nhg63nxk347blwq9f1qn6iiq3zisndcvm7axkq3pc2df"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -1609,21 +1610,8 @@ is Python’s.")
(add-after 'unpack 'remove-coverage-pytest-options
(lambda _
(substitute* "pyproject.toml"
- (("^--cov.*") ""))))
- ;; XXX: PEP 517 manual build copied from python-isort.
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest"))))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl)))))))
- (native-inputs (list python-poetry-core python-pypa-build python-pytest))
+ (("^--cov.*") "")))))))
+ (native-inputs (list python-poetry-core python-pytest))
(propagated-inputs
(list python-isodate
python-jsonschema