aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-10-28 09:58:47 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-10-28 09:59:11 +0200
commit332568d3e8b0022f9510e7b1e609524cb3131bf3 (patch)
tree74c8a0c4482e355cd10e1d0b2df5e1cc6bd4a7c7
parent3511ad28575cac04b3f2e7dae00042690192cbd2 (diff)
downloadguix-332568d3e8b0022f9510e7b1e609524cb3131bf3.tar
guix-332568d3e8b0022f9510e7b1e609524cb3131bf3.tar.gz
gnu: r-mixedpower: Improve compatibility with R>=4.2.
Upstream’s fix is incomplete and thus commit 7871447cf5d9fc5a7b5fe5277fc5e111e5ce32d7 was insufficient. * gnu/packages/patches/r-mixedpower-r2power.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/statistics.scm (r-mixedpower)[source]: Use it.
-rw-r--r--gnu/packages/patches/r-mixedpower-r2power.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/r-mixedpower-r2power.patch b/gnu/packages/patches/r-mixedpower-r2power.patch
new file mode 100644
index 0000000000..a3307ca7b5
--- /dev/null
+++ b/gnu/packages/patches/r-mixedpower-r2power.patch
@@ -0,0 +1,26 @@
+From e882fda905150649aa887c72731144330ca297b5 Mon Sep 17 00:00:00 2001
+From: Lars-Dominik Braun <lars@6xq.net>
+Date: Fri, 28 Oct 2022 09:18:11 +0200
+Subject: [PATCH] Fix R2power with R>=4.2
+
+The previous commit missed this if statement.
+---
+ R/meta_functions.R | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/R/meta_functions.R b/R/meta_functions.R
+index a65f0c1..fb3feba 100644
+--- a/R/meta_functions.R
++++ b/R/meta_functions.R
+@@ -172,7 +172,7 @@ R2power <- function(model, data, fixed_effects, simvar,
+ } # end if databased
+
+ # 2. SESOI
+- suppressWarnings(if (SESOI != F){ # supress warning generated by if statement if SESOI =! F
++ suppressWarnings(if (!is.logical(SESOI)){
+
+ # change beta coeficients to SESOI values
+ model@beta <- SESOI
+--
+2.37.4
+