aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-17 21:10:47 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:07 +0200
commit10f8534929cff8dbaf0ae4e0b2393143839ca97e (patch)
tree048bf153a12a38136e762410a67c86d11680a3bc
parent6f6257a6bcb3a672edd5586c6e9ab7e38dcc8775 (diff)
downloadguix-10f8534929cff8dbaf0ae4e0b2393143839ca97e.tar
guix-10f8534929cff8dbaf0ae4e0b2393143839ca97e.tar.gz
gnu: python-statmake: Use pyproject-build-system.
* gnu/packages/fontutils.scm (python-statmake)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD.
-rw-r--r--gnu/packages/fontutils.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index f797847802..f7f9ac3505 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1564,12 +1564,11 @@ generate bitmaps.")
(sha256
(base32
"0qavzspxhwnaayj5mxq6ncjjziggabxj157ls04h2rdrpq167706"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: PEP 517 manual build copied from python-isort.
(add-after 'unpack 'adjust-for-older-attrs
;; Our older attrs package is using the 'attr' rather than 'attrs'
;; namespace.
@@ -1586,27 +1585,9 @@ generate bitmaps.")
(("@attrs")
"@attr")
(("\\battrs\\.")
- "attr."))))
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests"
- ;;"-n" (number->string (parallel-job-count))
- ;; This test requires orjson, which needs the maturin
- ;; build system and new Rust dependencies.
- ;;"--ignore" "tests/test_preconf.py"
- )))))))
+ "attr.")))))))
(native-inputs
(list python-poetry-core
- python-pypa-build
python-pytest
python-ufo2ft))
(propagated-inputs