aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoshinori Arai <kumagusu08@gmail.com>2019-01-31 11:55:01 +0900
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 22:34:23 +0100
commitff75441fcf0ba1212b0342f933a8999bafe60f03 (patch)
treee0a1495692f33e9ba214551ecc4641caabbe2bc1
parent07c82daad4be31ac02479585a61254d4750626ff (diff)
downloadguix-ff75441fcf0ba1212b0342f933a8999bafe60f03.tar
guix-ff75441fcf0ba1212b0342f933a8999bafe60f03.tar.gz
gnu: Add xclock.
* gnu/packages/xorg.scm (xclock): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/xorg.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a43dfe89bd..bf7a4050a3 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2019 nee <nee@cock.li>
+;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5724,6 +5725,37 @@ user-friendly mechanism to start the X server.")
Intrinsics (Xt) Library.")
(license license:x11)))
+(define-public xclock
+ (package
+ (name "xclock")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.x.org/releases/individual/app/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "1l3xv4bsca6bwxx73jyjz0blav86i7vwffkhdb1ac81y9slyrki3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-appdefaultdir="
+ %output ,%app-defaults-dir))))
+ (inputs
+ `(("libxmu" ,libxmu)
+ ("libx11" ,libx11)
+ ("libxaw" ,libxaw)
+ ("libxrender" ,libxrender)
+ ("libxft" ,libxft)
+ ("libxkbfile" ,libxkbfile)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/")
+ (synopsis "Analog / digital clock for X")
+ (description "The xclock program displays the time in analog or digital
+form.")
+ (license (license:x11-style "file://COPYING" "See COPYING for details."))))
+
(define-public xmag
(package
(name "xmag")