aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-26 12:26:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-26 12:27:57 +0100
commite99d036828bd7d01bfd108f3d5a2f7de61fab32d (patch)
treec89f2b63bb3770b7da1d0496b011295d401a0c22
parent33eb63da646706380f74ac710740f12a0f0a7a8c (diff)
downloadguix-e99d036828bd7d01bfd108f3d5a2f7de61fab32d.tar
guix-e99d036828bd7d01bfd108f3d5a2f7de61fab32d.tar.gz
gnu: efl: Fix build on 32-bit architectures.
* gnu/packages/patches/efl-mesa-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/enlightenment.scm (efl)[source](patches): Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/enlightenment.scm1
-rw-r--r--gnu/packages/patches/efl-mesa-compat.patch21
3 files changed, 23 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a4507f5e99..62407351a0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -659,6 +659,7 @@ dist_patch_DATA = \
%D%/packages/patches/doxygen-test.patch \
%D%/packages/patches/dropbear-CVE-2018-15599.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
+ %D%/packages/patches/efl-mesa-compat.patch \
%D%/packages/patches/elfutils-tests-ptrace.patch \
%D%/packages/patches/einstein-build.patch \
%D%/packages/patches/emacs-exec-path.patch \
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 9989e2f5a8..d0ad44271e 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -70,6 +70,7 @@
(uri (string-append
"https://download.enlightenment.org/rel/libs/efl/efl-"
version ".tar.xz"))
+ (patches (search-patches "efl-mesa-compat.patch"))
(sha256
(base32
"0a5907h896pvpix7a6idc2fspzy6d78xrzf84k8y9fyvnd14nxs4"))))
diff --git a/gnu/packages/patches/efl-mesa-compat.patch b/gnu/packages/patches/efl-mesa-compat.patch
new file mode 100644
index 0000000000..6fe7b38428
--- /dev/null
+++ b/gnu/packages/patches/efl-mesa-compat.patch
@@ -0,0 +1,21 @@
+Fix build on 32-bit architectures with Mesa 18.3. Patch taken from upstream:
+
+https://git.enlightenment.org/core/efl.git/commit/?id=0d2b624f1e24240a1c4e651aa1cfe9a8dd10a573
+
+diff --git a/src/lib/evas/Evas_GL.h b/src/lib/evas/Evas_GL.h
+index b6b642400f..4f67b1695f 100644
+--- a/src/lib/evas/Evas_GL.h
++++ b/src/lib/evas/Evas_GL.h
+@@ -4272,9 +4272,11 @@ typedef signed int GLfixed; // Changed khronos_int32_t
+
+ #ifndef GL_ES_VERSION_2_0
+ /* GL types for handling large vertex buffer objects */
+-#include <stddef.h>
++# ifndef GL_VERSION_1_5
++# include <stddef.h>
+ typedef ptrdiff_t GLintptr; // Changed khronos_intptr_t
+ typedef ptrdiff_t GLsizeiptr; // Changed khronos_ssize_t
++# endif
+ #endif
+
+ /* Some definitions from GLES 3.0.