aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-13 11:49:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-13 11:50:55 +0200
commitad79ae7e2d7505292b11e87302b08f4db0f934e9 (patch)
tree7443680f7c5ee26c708e6ea753ec1fc7b5f6ba14
parent6764f94317be05d2c3b08acdcbb2c4730f0c617d (diff)
downloadguix-ad79ae7e2d7505292b11e87302b08f4db0f934e9.tar
guix-ad79ae7e2d7505292b11e87302b08f4db0f934e9.tar.gz
gnu: bitshuffle-for-snappy: Inherit package arguments.
* gnu/packages/compression.scm (bitshuffle-for-snappy)[arguments]: Inherit package arguments from bitshuffle. Always skip tests.
-rw-r--r--gnu/packages/compression.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1c1276dc82..ea3d72c011 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1269,14 +1269,15 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
(name "bitshuffle-for-snappy")
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (with-output-to-file "Makefile"
- (lambda _
- (format #t "\
+ (substitute-keyword-arguments (package-arguments bitshuffle)
+ ((#:tests? _ #f) #f)
+ ((#:phases phases)
+ `(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "Makefile"
+ (lambda _
+ (format #t "\
libbitshuffle.so: src/bitshuffle.o src/bitshuffle_core.o src/iochain.o lz4/lz4.o
\tgcc -O3 -ffast-math -std=c99 -o $@ -shared -fPIC $^
@@ -1296,7 +1297,7 @@ install: libbitshuffle.so
\tinstall -m644 src/iochain.h $(INCLUDEDIR)
\tinstall -m644 lz4/lz4.h $(INCLUDEDIR)
" (assoc-ref outputs "out"))))
- #t)))))
+ #t))))))
(inputs '())
(native-inputs '())))