aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-01-17 00:18:41 +0000
committerLudovic Courtès <ludo@gnu.org>2019-02-09 23:27:12 +0100
commit93d3360ab01d7115eba8972990519cdd1d5e21b1 (patch)
tree725315ca1886dd289d6ed10620a226808545f5fb
parent20310a7e92f2213ac6fa22c26feccd1a8904e0c7 (diff)
downloadguix-93d3360ab01d7115eba8972990519cdd1d5e21b1.tar
guix-93d3360ab01d7115eba8972990519cdd1d5e21b1.tar.gz
gnu: Add python-aiorpcx.
* gnu/packages/python-web.scm (python-aiorpcx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61f3a194a7..afec5ebc30 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -145,6 +146,31 @@ asynchronous DNS resolutions with a synchronous looking interface by
using @url{https://github.com/saghul/pycares,pycares}.")
(license license:expat)))
+(define-public python-aiorpcx
+ (package
+ (name "python-aiorpcx")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiorpcX" version))
+ (sha256
+ (base32
+ "1p88k15jh0d2a18pnnbfcamsqi2bxvmmhpizmdlxfdxf8vy5ggyj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)))
+ (home-page "https://github.com/kyuupichan/aiorpcX")
+ (synopsis "Generic asyncio RPC implementation")
+ (description
+ "aiorpcX is a generic asyncio library implementation of RPC suitable for
+an application that is a client, server or both.
+
+The package includes a module with full coverage of JSON RPC versions 1.0 and
+2.0, JSON RPC protocol auto-detection, and arbitrary message framing. It also
+comes with a SOCKS proxy client.")
+ (license (list license:expat license:bsd-2))))
+
(define-public python-falcon
(package
(name "python-falcon")