aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-02 18:53:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-02 20:10:18 +0100
commit85765054221de172049eeec5676da139212916a2 (patch)
treedcb17a31ac2a83bd138095da8566eabd953cefb5
parent0747328e317de4bf936fab50e795d1e1523adfc1 (diff)
downloadguix-85765054221de172049eeec5676da139212916a2.tar
guix-85765054221de172049eeec5676da139212916a2.tar.gz
gnu: libreoffice: Fix FTBFS with Boost 1.69.0.
* gnu/packages/patches/libreoffice-boost.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libreoffice.scm (libreoffice)[source](patches): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libreoffice.scm3
-rw-r--r--gnu/packages/patches/libreoffice-boost.patch17
3 files changed, 20 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ee8b13d2fb..a63f595b30 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -977,6 +977,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-mips-newgcc.patch \
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
+ %D%/packages/patches/libreoffice-boost.patch \
%D%/packages/patches/libreoffice-icu.patch \
%D%/packages/patches/libreoffice-glm.patch \
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2824d87fc6..b047c34a0b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -997,7 +997,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(sha256
(base32
"1dsd0gynjf7d6412dd2sx70xa2s8kld7ibyjdkwg5w9hhi2zxw2f"))))
- (search-patches "libreoffice-icu.patch"
+ (search-patches "libreoffice-boost.patch"
+ "libreoffice-icu.patch"
"libreoffice-glm.patch")))
(modules '((guix build utils)))
(snippet
diff --git a/gnu/packages/patches/libreoffice-boost.patch b/gnu/packages/patches/libreoffice-boost.patch
new file mode 100644
index 0000000000..b50664226b
--- /dev/null
+++ b/gnu/packages/patches/libreoffice-boost.patch
@@ -0,0 +1,17 @@
+Fix compatibility with newer Boost.
+
+Extracted from this upstream commit:
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
+
+diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
+--- a/sfx2/source/appl/shutdownicon.cxx
++++ b/sfx2/source/appl/shutdownicon.cxx
+@@ -144,7 +144,7 @@ bool LoadModule()
+ #endif // ENABLE_QUICKSTART_APPLET
+ }
+ assert(!boost::logic::indeterminate(loaded));
+- return loaded;
++ return bool(loaded);
+ }
+
+ }