aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-31 10:26:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-31 10:26:32 +0200
commit47970cf66ce1817d79a09dbc8e5a9e3af262b242 (patch)
tree904a0798a0e553dee6cee3b4e730989b4f843b24
parent5dc5c5ea41fd72b0999c043148615bb2e585fe85 (diff)
downloadguix-47970cf66ce1817d79a09dbc8e5a9e3af262b242.tar
guix-47970cf66ce1817d79a09dbc8e5a9e3af262b242.tar.gz
gnu: wesnoth: Fix building with newer boost.
* gnu/packages/games.scm (wesnoth)[source]: Add patch. * gnu/packages/patches/wenoth-newer-boost.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/games.scm3
-rw-r--r--gnu/packages/patches/wesnoth-newer-boost.patch46
3 files changed, 49 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5b117595b9..050d174f5b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1237,6 +1237,7 @@ dist_patch_DATA = \
%D%/packages/patches/wavpack-CVE-2018-7253.patch \
%D%/packages/patches/wavpack-CVE-2018-7254.patch \
%D%/packages/patches/weechat-python.patch \
+ %D%/packages/patches/wesnoth-newer-boost.patch \
%D%/packages/patches/wicd-bitrate-none-fix.patch \
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
%D%/packages/patches/wicd-urwid-1.3.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7896c9c3f4..423c977de5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2141,7 +2141,8 @@ falling, themeable graphics and sounds, and replays.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1kgpj2f22nnx4mwd1zis3s5ny2983aasgqsmz7wnqaq7n6a7ac85"))))
+ "1kgpj2f22nnx4mwd1zis3s5ny2983aasgqsmz7wnqaq7n6a7ac85"))
+ (patches (search-patches "wesnoth-newer-boost.patch"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no check target
diff --git a/gnu/packages/patches/wesnoth-newer-boost.patch b/gnu/packages/patches/wesnoth-newer-boost.patch
new file mode 100644
index 0000000000..d48a48e801
--- /dev/null
+++ b/gnu/packages/patches/wesnoth-newer-boost.patch
@@ -0,0 +1,46 @@
+https://github.com/wesnoth/wesnoth/commit/f6a32792d023d182d350b5a2ed9e469ad67484c8.patch
+This should be able to be removed with wesnoth@1.14.6
+
+From f6a32792d023d182d350b5a2ed9e469ad67484c8 Mon Sep 17 00:00:00 2001
+From: Wedge009 <wedge009@wedge009.net>
+Date: Thu, 27 Dec 2018 08:15:10 +1100
+Subject: [PATCH] Use explicit casts to accommodate changes to boost's tribool
+ in 1.69.
+
+(fixes #3646)
+---
+ src/units/frame.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/units/frame.cpp b/src/units/frame.cpp
+index 3215fa4fa79d..6370ad69566b 100644
+--- a/src/units/frame.cpp
++++ b/src/units/frame.cpp
+@@ -460,15 +460,15 @@ std::vector<std::string> frame_parsed_parameters::debug_strings() const
+ }
+
+ if(!boost::indeterminate(auto_vflip_)) {
+- v.emplace_back("auto_vflip=" + utils::bool_string(auto_vflip_));
++ v.emplace_back("auto_vflip=" + utils::bool_string(static_cast<bool>(auto_vflip_)));
+ }
+
+ if(!boost::indeterminate(auto_hflip_)) {
+- v.emplace_back("auto_hflip=" + utils::bool_string(auto_hflip_));
++ v.emplace_back("auto_hflip=" + utils::bool_string(static_cast<bool>(auto_hflip_)));
+ }
+
+ if(!boost::indeterminate(primary_frame_)) {
+- v.emplace_back("primary_frame=" + utils::bool_string(primary_frame_));
++ v.emplace_back("primary_frame=" + utils::bool_string(static_cast<bool>(primary_frame_)));
+ }
+
+ if(!drawing_layer_.get_original().empty()) {
+@@ -768,7 +768,7 @@ const frame_parameters unit_frame::merge_parameters(int current_time, const fram
+ }
+
+ // Convert the tribool to bool
+- const bool primary = result.primary_frame == true || boost::logic::indeterminate(result.primary_frame);
++ const bool primary = static_cast<bool>(result.primary_frame) || boost::logic::indeterminate(result.primary_frame);
+
+ /** The engine provides a default image to use for the unit when none is available */
+ result.image = current_val.image.is_void() || current_val.image.get_filename().empty()