aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-02-09 22:19:17 +0100
committerRutger Helling <rhelling@mykolab.com>2019-02-09 22:23:14 +0100
commit44ad1c16e2e681f0b9cc35dc2a1b8d7e685cbe48 (patch)
tree29bec7a04889d751747d8c10a81a6fe0b6710c0a
parentaefa29123feaf4202010675eae0a563b3ee90cf1 (diff)
downloadguix-44ad1c16e2e681f0b9cc35dc2a1b8d7e685cbe48.tar
guix-44ad1c16e2e681f0b9cc35dc2a1b8d7e685cbe48.tar.gz
gnu: Add spice-protocol@0.12.14.
* gnu/packages/spice.scm (spice-protocol@0.12.14): New variable.
-rw-r--r--gnu/packages/spice.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 6a580c6226..77939bc8a8 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,6 +114,22 @@ which allows users to view a desktop computing environment.")
(home-page "https://www.spice-space.org")
(license (list license:bsd-3 license:lgpl2.1+))))
+;; TODO: Package lookingglass doesn't build with spice-protocol 0.12.15. Remove
+;; below once that is fixed.
+(define-public spice-protocol-0.12.14
+ (package
+ (inherit spice-protocol)
+ (name "spice-protocol")
+ (version "0.12.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.spice-space.org/download/releases/"
+ "spice-protocol-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "170ckpgazvqv7hxy209myg67pqnd6c0gvr4ysbqgsfch6320nd90"))))))
+
(define-public spice-gtk
(package
(name "spice-gtk")