aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-04 16:42:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 20:49:11 +0100
commit10b96d2955f1ce20b3916cdf235670eceb48d806 (patch)
treed2c4a897cb528f70240d0739bc31ec9d6f05c50a
parent56a88478b908110b513f8c9c767c32facf1b202d (diff)
downloadguix-10b96d2955f1ce20b3916cdf235670eceb48d806.tar
guix-10b96d2955f1ce20b3916cdf235670eceb48d806.tar.gz
gnu: ALSA: Update to 1.1.7.
* gnu/packages/linux.scm (alsa-lib), alsa-utils): Update to 1.1.7. (alsa-plugins): Likewise. [arguments]: Add #:configure-flags. Prevent default configuration from being installed. Don't copy the example PulseAudio configuration to pulseaudio output.
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 14 insertions, 19 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3d88b74daf..24653dfbe2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -993,7 +993,7 @@ intercept and print the system calls executed by the program.")
(define-public alsa-lib
(package
(name "alsa-lib")
- (version "1.1.6")
+ (version "1.1.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1001,7 +1001,7 @@ intercept and print the system calls executed by the program.")
version ".tar.bz2"))
(sha256
(base32
- "096pwrnhj36yndldvs2pj4r871zhcgisks0is78f1jkjn9sd4b2z"))))
+ "02fw7dw202mjid49w9ki3dsfcyvid5fj488561bdzcm3haw00q4x"))))
(build-system gnu-build-system)
(home-page "https://www.alsa-project.org/")
(synopsis "The Advanced Linux Sound Architecture libraries")
@@ -1013,14 +1013,14 @@ MIDI functionality to the Linux-based operating system.")
(define-public alsa-utils
(package
(name "alsa-utils")
- (version "1.1.6")
+ (version "1.1.7")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.alsa-project.org/pub/utils/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "0vnkyymgwj9rfdb11nvab30dnfrylmakdfildxl0y8mj836awp0m"))))
+ "02jlw6a22j2rr7inggfgk2hzx3w0fjhvhs0dn1afpzdp9aspzchx"))))
(build-system gnu-build-system)
(arguments
;; XXX: Disable man page creation until we have DocBook.
@@ -1060,14 +1060,14 @@ MIDI functionality to the Linux-based operating system.")
(define-public alsa-plugins
(package
(name "alsa-plugins")
- (version "1.1.6")
+ (version "1.1.7")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "04qcwkisbh0d6lnh0rw1k6n869fbs6zbfq6yvb41rymiwgmk27bg"))))
+ "0iys4zl1davzyg3mn9lvil1n3k1ifrg3v1caj3k4dqyrnrd40jx7"))))
(build-system gnu-build-system)
;; TODO: Split libavcodec and speex if possible. It looks like they can not
;; be split, there are references to both in files.
@@ -1076,7 +1076,12 @@ MIDI functionality to the Linux-based operating system.")
;; obsolete.
(outputs '("out" "pulseaudio" "jack"))
(arguments
- `(#:phases
+ `(#:configure-flags '(;; Do not install a "local" configuration targeted
+ ;; for /etc/alsa. On GuixSD plugins are loaded from
+ ;; the ALSA service, and other distributions likely
+ ;; won't use these files.
+ "--with-alsalconfdir=/tmp/noop")
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'split
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -1085,27 +1090,17 @@ MIDI functionality to the Linux-based operating system.")
(jack (assoc-ref outputs "jack"))
(jacklib (string-append jack "/lib/alsa-lib"))
(pua (assoc-ref outputs "pulseaudio"))
- (pualib (string-append pua "/lib/alsa-lib"))
- (puaconf (string-append pua "/share/alsa/alsa.conf.d")))
+ (pualib (string-append pua "/lib/alsa-lib")))
;; For jack.
(mkdir-p jacklib)
(for-each (lambda (file)
(rename-file file (string-append jacklib "/" (basename file))))
(find-files out ".*jack\\.(la|so)"))
- ;; For pluseaudio.
- (mkdir-p puaconf)
+ ;; For pulseaudio.
(mkdir-p pualib)
- (chdir (string-append out "/share"))
- (for-each (lambda (file)
- (rename-file file (string-append puaconf "/" (basename file))))
- (find-files out "\\.(conf|example)"))
(for-each (lambda (file)
(rename-file file (string-append pualib "/" (basename file))))
(find-files out ".*pulse\\.(la|so)"))
- (chdir "..")
- ;; We have moved the files to output pulsaudio, the
- ;; directory is now empty.
- (delete-file-recursively (string-append out "/share"))
#t))))))
(inputs
`(("alsa-lib" ,alsa-lib)