aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-22 15:00:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 20:58:15 +0100
commit0ea0452c0a36fbf6349628e5a5792a707706ec18 (patch)
tree30543e2892144022b3728c9e388b236c099dafb5
parent50a93adc05b611836e740c4b55571890f4c6770a (diff)
downloadguix-0ea0452c0a36fbf6349628e5a5792a707706ec18.tar
guix-0ea0452c0a36fbf6349628e5a5792a707706ec18.tar.gz
gnu: Add xbanish.
* gnu/packages/xdisorg.scm (xbanish): New public variable.
-rw-r--r--gnu/packages/xdisorg.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4d61dd8dbc..5f01c8c6a6 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
@@ -641,6 +641,36 @@ to find buttons, etc, on the screen to click on.")
(home-page "https://www.hoopajoo.net/projects/xautomation.html")
(license license:gpl2+)))
+(define-public xbanish
+ (package
+ (name "xbanish")
+ (version "1.6")
+ (home-page "https://github.com/jcs/xbanish")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0vp8ja68hpmqkl61zyjar3czhmny1hbm74m8f393incfz1ymr3i8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxfixes" ,libxfixes)
+ ("libxi" ,libxi)
+ ("libxt" ,libxt)))
+ (synopsis "Banish the mouse cursor")
+ (description
+ "@command{xbanish} hides the mouse cursor when you start typing, and
+shows it again when the mouse cursor moves or a mouse button is pressed.")
+ (license license:bsd-3)))
+
(define-public xlockmore
(package
(name "xlockmore")