aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-05 20:04:57 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-09 08:21:42 +0000
commit8f182d77f4e5c708a728148d6926d2ec1e66067d (patch)
treeee31b21f07932d3a2c9810b3f1f8e46f8345c09e
parentb29648b1eac5d3a04749b47ca5e7eb4715ae1e0d (diff)
downloadguix-8f182d77f4e5c708a728148d6926d2ec1e66067d.tar
guix-8f182d77f4e5c708a728148d6926d2ec1e66067d.tar.gz
Upgrade python-ipython
-rw-r--r--gnu/packages/python.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2715cf6d8d..5cadc89d06 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4819,22 +4819,24 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python-ipython
(package
(name "python-ipython")
- (version "5.5.0")
+ (version "7.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ipython" version ".tar.gz"))
(sha256
- (base32 "03qmzpfy00if10i9k8fjkam1s4xg22j73f933x5d228z9n4rwik6"))))
+ (base32 "04nxpgv05qizmwcr5swbndaizbwsj4lbjshjxhfkyiknkch9d53a"))))
(build-system python-build-system)
(outputs '("out" "doc"))
(propagated-inputs
- `(("python-pyzmq" ,python-pyzmq)
+ `(("python-backcall" ,python-backcall)
+ ("python-pyzmq" ,python-pyzmq)
("python-prompt-toolkit" ,python-prompt-toolkit)
("python-terminado" ,python-terminado)
("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
("python-numpydoc" ,python-numpydoc)
+ ("python-jedi" ,python-jedi)
("python-jinja2" ,python-jinja2)
("python-jupyter-console"
;; The python-ipython and python-jupyter-console require each