aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-08 00:44:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-08 19:37:47 +0100
commit7570ec5aa96d459aa41ddfaf459a883be89848d4 (patch)
tree76b5b970ac2bdec0cc594a5c53bdfad35f015c42
parent8d65ae44ac9492b17266aa1bbe04d562e904946a (diff)
downloadguix-7570ec5aa96d459aa41ddfaf459a883be89848d4.tar
guix-7570ec5aa96d459aa41ddfaf459a883be89848d4.tar.gz
gnu: GCC@7: Update to 7.4.0.
* gnu/packages/gcc.scm (gcc-7): Update to 7.4.0. [source](patches): Drop 'gcc-libsanitizer-ustat.patch'. * gnu/packages/storage.scm (ceph)[inputs]: Change from BOOST to BOOST-CXX14, as GCC 7.4.0 triggers <https://bugs.gnu.org/33605>.
-rw-r--r--gnu/packages/gcc.scm5
-rw-r--r--gnu/packages/storage.scm2
2 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index fb06b53474..1f1e80dde8 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -490,16 +490,15 @@ Go. It also includes runtime support libraries for these languages.")
(define-public gcc-7
(package
(inherit gcc-6)
- (version "7.3.0")
+ (version "7.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.xz"))
(sha256
(base32
- "0p71bij6bfhzyrs8676a8jmpjsfz392s2rg862sdnsk30jpacb43"))
+ "0lgy170b0pp60j9cczqkmaqyjjb584vfamj4c30swd7k0j6y5pgd"))
(patches (search-patches "gcc-strmov-store-file-names.patch"
- "gcc-libsanitizer-ustat.patch"
"gcc-5.0-libvtv-runpath.patch"))))
(description
"GCC is the GNU Compiler Collection. It provides compiler front-ends
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 5051ccd986..4eae37815e 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -321,7 +321,7 @@
("python2-testtools" ,python2-testtools)
("python2-tox" ,python2-tox)))
(inputs
- `(("boost" ,boost)
+ `(("boost" ,boost-cxx14)
("curl" ,curl)
("cryptsetup" ,cryptsetup)
("expat" ,expat)