aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-07 14:16:07 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-07 15:14:12 +0100
commit6eac835f178c0c78637b0db8a4585a617b2f7622 (patch)
tree52c2fcaf3ef21158557202a892a4b0c44bfd11ed
parented9c8eb4e5f4ab5d51e3bb27ccb17bd5b43bb803 (diff)
downloadguix-6eac835f178c0c78637b0db8a4585a617b2f7622.tar
guix-6eac835f178c0c78637b0db8a4585a617b2f7622.tar.gz
maint: update-guix-package: Really register GC roots.
Previously we'd pass a relative file name to 'add-indirect-root', which the daemon would interpret as relative to "/". Consequently, checkouts were not protected from GC. * build-aux/update-guix-package.scm (main): Pass an absolute file name to 'add-indirect-root'.
-rw-r--r--build-aux/update-guix-package.scm5
-rw-r--r--gnu/packages/package-management.scm6
2 files changed, 6 insertions, 5 deletions
diff --git a/build-aux/update-guix-package.scm b/build-aux/update-guix-package.scm
index 9598872dfd..83f6eca6bb 100644
--- a/build-aux/update-guix-package.scm
+++ b/build-aux/update-guix-package.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -133,7 +133,8 @@ COMMIT."
;; Add an indirect GC root for SOURCE in the current directory.
(false-if-exception (delete-file root))
(symlink source root)
- (add-indirect-root store root)
+ (add-indirect-root store
+ (string-append (getcwd) "/" root))
(format #t "source code for commit ~a: ~a (GC root: ~a)~%"
commit source root)))))
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 588f8bbcef..4dd025786b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -102,8 +102,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "0.16.0")
- (commit "c845323d4b0a31ce5241a9d98187e1eeed43f71c")
- (revision 1))
+ (commit "5227d938e2b7bda22e2a7aa733e1e09a6c726f18")
+ (revision 2))
(package
(name "guix")
@@ -119,7 +119,7 @@
(commit commit)))
(sha256
(base32
- "0i431d5p9ckr7kxfiwpp94wgjgqn6mgyypf0smw64bk635fn6ycr"))
+ "0v1a99k0qpxa5ksgqqwydd1nb00hkd71fj7374rqhklvk0a2cdz9"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments