aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-05 18:52:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:02 +0000
commit7b187be9b737068b54f414a774a01e4c3eb075f0 (patch)
tree86b4f86307813a5f4c4b3bddbd8e6178ed58262a
parent149837f060b0ffcffe03a8e90fa0099f54ec5221 (diff)
downloadguix-7b187be9b737068b54f414a774a01e4c3eb075f0.tar
guix-7b187be9b737068b54f414a774a01e4c3eb075f0.tar.gz
gnu: python-waitress: Adjust inputs.
* gnu/packages/python-xyz.scm (python-waitress) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ifeb7bf263c2eb056f8249d7124ec48717de162f6
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 452c641ee2..dbbe966db1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19975,11 +19975,16 @@ templates into Python modules.")
(arguments
;; https://github.com/Pylons/waitress/issues/443
(list #:test-flags #~(list "-k" "not test_service_port")))
- (native-inputs (list python-pytest python-pytest-cov))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/Pylons/waitress")
(synopsis "Waitress WSGI server")
- (description "Waitress is meant to be a production-quality pure-Python WSGI
-server with very acceptable performance.")
+ (description
+ "Waitress is meant to be a production-quality pure-Python WSGI server
+with very acceptable performance.")
(license license:zpl2.1)))
(define-public python-whatthepatch