aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-02 10:49:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-02 10:49:06 +0100
commit2756c660fb2d9e2fe3e1fd0898e4d7038c8273c7 (patch)
tree8d3fcb3c0a5111616e0b3a932dd8ebbd1e0bffb5
parent207c69e40d3dca947137dbfcd0564e610b17832d (diff)
downloadguix-2756c660fb2d9e2fe3e1fd0898e4d7038c8273c7.tar
guix-2756c660fb2d9e2fe3e1fd0898e4d7038c8273c7.tar.gz
gnu: python-pairtools: Update to 1.1.0-fix.
* gnu/packages/bioinformatics.scm (python-pairtools): Update to 1.1.0-fix. [build-system]: Use pyproject-build-system. [arguments]: Add phase 'patch-setup.py. [native-inputs]: Add python-pytest-cov, python-setuptools, and python-wheel. Change-Id: Ifa3c12de228420d8fdd7b0053bb9da80b9b3efe4
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82d4e84b6c..4e850ab562 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3572,20 +3572,26 @@ e.g. microbiome samples, genomes, metagenomes.")
(define-public python-pairtools
(package
(name "python-pairtools")
- (version "1.0.2")
+ (version "1.1.0-fix")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/open2c/pairtools")
- (commit (string-append "v" version))))
+ (commit (string-append "pairtools-v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0xn4cg4jq3rfn42h8rfwg0k6xkvihjrv32gwldb9y0jp05lzw9cs"))))
- (build-system python-build-system)
+ "0983vw4kb6frjncsnml4ahw3l7sixg1paz80s119iah2i086cw06"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.py
+ (lambda _
+ ;; __NUMPY_SETUP__ is undefined.
+ (substitute* "setup.py"
+ ((".*__builtins__.__NUMPY_SETUP.*") ""))))
(add-after 'unpack 'fix-references
(lambda _
(substitute* '("pairtools/cli/header.py"
@@ -3598,7 +3604,11 @@ e.g. microbiome samples, genomes, metagenomes.")
(with-directory-excursion "/tmp"
(invoke "pytest" "-v"))))))))
(native-inputs
- (list python-cython python-pytest))
+ (list python-cython
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list htslib ; for bgzip, looked up in PATH
samtools ; looked up in PATH